ath79: add support for D-link DAP-1720 A1
[openwrt/staging/wigyori.git] / target / linux / ath79 / image / generic.mk
index e6e78b9287517fb17ff144beaa071fc060eaaa08..e435806c7bb4b8fba6076673133204a64b1be6b1 100644 (file)
@@ -1053,6 +1053,22 @@ define Device/dlink_dap-1365-a1
 endef
 TARGET_DEVICES += dlink_dap-1365-a1
 
+define Device/dlink_dap-1720-a1
+  $(Device/seama)
+  SOC := qca9563
+  DEVICE_VENDOR := D-Link
+  DEVICE_MODEL := DAP-1720
+  DEVICE_VARIANT := A1
+  DEVICE_PACKAGES := rssileds -swconfig \
+       kmod-ath10k-ct-smallbuffers ath10k-firmware-qca988x-ct
+  SEAMA_SIGNATURE := wapac28_dlink.2015_dap1720
+  IMAGE_SIZE := 15872k
+  IMAGES += recovery.bin
+  IMAGE/recovery.bin := $$(IMAGE/default) | pad-rootfs -x 64 | seama | \
+       seama-seal | check-size
+endef
+TARGET_DEVICES += dlink_dap-1720-a1
+
 define Device/dlink_dap-2xxx
   IMAGES += factory.img
   IMAGE/factory.img := append-kernel | pad-offset 6144k 160 | \