ath79: drop, its not ready for a release yet
[openwrt/staging/blogic.git] / target / linux / ath79 / patches-4.14 / 0026-MIPS-ath79-sanitize-Kconfig-symbols.patch
diff --git a/target/linux/ath79/patches-4.14/0026-MIPS-ath79-sanitize-Kconfig-symbols.patch b/target/linux/ath79/patches-4.14/0026-MIPS-ath79-sanitize-Kconfig-symbols.patch
deleted file mode 100644 (file)
index f990651..0000000
+++ /dev/null
@@ -1,111 +0,0 @@
-From deda44895d289a72a235359fc21f8a62ea44dc1c Mon Sep 17 00:00:00 2001
-From: John Crispin <john@phrozen.org>
-Date: Tue, 6 Mar 2018 09:33:26 +0100
-Subject: [PATCH 26/27] MIPS: ath79: sanitize Kconfig symbols
-
-Signed-off-by: John Crispin <john@phrozen.org>
----
- arch/mips/Kconfig        |  2 ++
- arch/mips/ath79/Kconfig  | 48 +++++-------------------------------------------
- arch/mips/ath79/Makefile | 10 ----------
- arch/mips/pci/Makefile   |  2 +-
- 4 files changed, 8 insertions(+), 54 deletions(-)
-
---- a/arch/mips/Kconfig
-+++ b/arch/mips/Kconfig
-@@ -203,6 +203,8 @@ config ATH79
-       select SYS_SUPPORTS_BIG_ENDIAN
-       select SYS_SUPPORTS_MIPS16
-       select SYS_SUPPORTS_ZBOOT_UART_PROM
-+      select HW_HAS_PCI
-+      select USB_ARCH_HAS_EHCI
-       select USE_OF
-       help
-         Support for the Atheros AR71XX/AR724X/AR913X SoCs.
---- a/arch/mips/ath79/Kconfig
-+++ b/arch/mips/ath79/Kconfig
-@@ -1,52 +1,14 @@
- # SPDX-License-Identifier: GPL-2.0
- if ATH79
--config SOC_AR71XX
--      select HW_HAS_PCI
--      def_bool n
--
--config SOC_AR724X
--      select HW_HAS_PCI
--      select PCI_AR724X if PCI
--      def_bool n
--
--config SOC_AR913X
--      def_bool n
--
--config SOC_AR933X
--      def_bool n
--
--config SOC_AR934X
--      select HW_HAS_PCI
--      select PCI_AR724X if PCI
--      def_bool n
--
--config SOC_QCA953X
--      select USB_ARCH_HAS_EHCI
--      def_bool n
--
--config SOC_QCA955X
--      select HW_HAS_PCI
--      select PCI_AR724X if PCI
-+config PCI_AR71XX
-+      bool "PCI support for AR7100 type SoCs"
-+      depends on PCI
-       def_bool n
- config PCI_AR724X
--      def_bool n
--
--config ATH79_DEV_GPIO_BUTTONS
--      def_bool n
--
--config ATH79_DEV_LEDS_GPIO
--      def_bool n
--
--config ATH79_DEV_SPI
--      def_bool n
--
--config ATH79_DEV_USB
--      def_bool n
--
--config ATH79_DEV_WMAC
--      depends on (SOC_AR913X || SOC_AR933X || SOC_AR934X || SOC_QCA953X || SOC_QCA955X || SOC_QCA956X)
-+      bool "PCI support for AR724x type SoCs"
-+      depends on PCI
-       def_bool n
- endif
---- a/arch/mips/ath79/Makefile
-+++ b/arch/mips/ath79/Makefile
-@@ -11,13 +11,3 @@
- obj-y := prom.o setup.o common.o clock.o
- obj-$(CONFIG_EARLY_PRINTK)            += early_printk.o
--
--#
--# Devices
--#
--obj-y                                 += dev-common.o
--obj-$(CONFIG_ATH79_DEV_GPIO_BUTTONS)  += dev-gpio-buttons.o
--obj-$(CONFIG_ATH79_DEV_LEDS_GPIO)     += dev-leds-gpio.o
--obj-$(CONFIG_ATH79_DEV_SPI)           += dev-spi.o
--obj-$(CONFIG_ATH79_DEV_USB)           += dev-usb.o
--obj-$(CONFIG_ATH79_DEV_WMAC)          += dev-wmac.o
---- a/arch/mips/pci/Makefile
-+++ b/arch/mips/pci/Makefile
-@@ -23,7 +23,7 @@ obj-$(CONFIG_BCM63XX)                += pci-bcm63xx.o
-                                       ops-bcm63xx.o
- obj-$(CONFIG_MIPS_ALCHEMY)    += pci-alchemy.o
- obj-$(CONFIG_PCI_AR2315)      += pci-ar2315.o
--obj-$(CONFIG_SOC_AR71XX)      += pci-ar71xx.o
-+obj-$(CONFIG_PCI_AR71XX)      += pci-ar71xx.o
- obj-$(CONFIG_PCI_AR724X)      += pci-ar724x.o
- obj-$(CONFIG_MIPS_PCI_VIRTIO) += pci-virtio-guest.o
- #