ath79: Remove kernel 4.14 support
[openwrt/openwrt.git] / target / linux / ath79 / patches-4.14 / 404-mtd-cybertan-trx-parser.patch
diff --git a/target/linux/ath79/patches-4.14/404-mtd-cybertan-trx-parser.patch b/target/linux/ath79/patches-4.14/404-mtd-cybertan-trx-parser.patch
deleted file mode 100644 (file)
index 3cc0b0d..0000000
+++ /dev/null
@@ -1,19 +0,0 @@
---- a/drivers/mtd/parsers/Makefile
-+++ b/drivers/mtd/parsers/Makefile
-@@ -1 +1,2 @@
-+obj-$(CONFIG_MTD_PARSER_CYBERTAN)     += parser_cybertan.o
- obj-$(CONFIG_MTD_PARSER_TRX)          += parser_trx.o
---- a/drivers/mtd/parsers/Kconfig
-+++ b/drivers/mtd/parsers/Kconfig
-@@ -1,3 +1,11 @@
-+config MTD_PARSER_CYBERTAN
-+      tristate "Parser for Cybertan format partitions"
-+      depends on MTD && (ATH79 || COMPILE_TEST)
-+      help
-+        Cybertan has a proprietory header than encompasses a Broadcom trx
-+        header. This driver will parse the header and take care of the
-+        special offsets that result in the extra headers.
-+
- config MTD_PARSER_TRX
-       tristate "Parser for TRX format partitions"
-       depends on MTD && (BCM47XX || ARCH_BCM_5301X || COMPILE_TEST)