ath79: refresh patches and configs to introduce kernel 6.1 support
[openwrt/staging/blocktrron.git] / target / linux / ath79 / patches-6.1 / 910-mikrotik-rb4xx.patch
index 4743ad46e2522e6b3c4654d86e1e86959e14b925..b61eef0b8a88baa1093c6eca7b5a12de43a507d2 100644 (file)
@@ -45,7 +45,7 @@ Submitted-by: Christopher Hill <ch6574@gmail.com>
 
 --- a/drivers/mfd/Kconfig
 +++ b/drivers/mfd/Kconfig
-@@ -2176,6 +2176,14 @@ config RAVE_SP_CORE
+@@ -2208,6 +2208,14 @@ config RAVE_SP_CORE
          Select this to get support for the Supervisory Processor
          device found on several devices in RAVE line of hardware.
  
@@ -62,7 +62,7 @@ Submitted-by: Christopher Hill <ch6574@gmail.com>
        depends on PCI && MIPS && 64BIT
 --- a/drivers/mfd/Makefile
 +++ b/drivers/mfd/Makefile
-@@ -267,6 +267,7 @@ obj-$(CONFIG_MFD_KHADAS_MCU)       += khadas-
+@@ -269,6 +269,7 @@ obj-$(CONFIG_MFD_KHADAS_MCU)       += khadas-
  obj-$(CONFIG_MFD_ACER_A500_EC)        += acer-ec-a500.o
  obj-$(CONFIG_MFD_QCOM_PM8008) += qcom-pm8008.o
  
@@ -72,7 +72,7 @@ Submitted-by: Christopher Hill <ch6574@gmail.com>
  obj-$(CONFIG_MFD_INTEL_M10_BMC)   += intel-m10-bmc.o
 --- a/drivers/gpio/Kconfig
 +++ b/drivers/gpio/Kconfig
-@@ -1574,6 +1574,12 @@ config GPIO_SODAVILLE
+@@ -1593,6 +1593,12 @@ config GPIO_SODAVILLE
        help
          Say Y here to support Intel Sodaville GPIO.
  
@@ -87,7 +87,7 @@ Submitted-by: Christopher Hill <ch6574@gmail.com>
  menu "SPI GPIO expanders"
 --- a/drivers/gpio/Makefile
 +++ b/drivers/gpio/Makefile
-@@ -122,6 +122,7 @@ obj-$(CONFIG_GPIO_PL061)           += gpio-pl061.
+@@ -123,6 +123,7 @@ obj-$(CONFIG_GPIO_PL061)           += gpio-pl061.
  obj-$(CONFIG_GPIO_PMIC_EIC_SPRD)      += gpio-pmic-eic-sprd.o
  obj-$(CONFIG_GPIO_PXA)                        += gpio-pxa.o
  obj-$(CONFIG_GPIO_RASPBERRYPI_EXP)    += gpio-raspberrypi-exp.o
@@ -97,7 +97,7 @@ Submitted-by: Christopher Hill <ch6574@gmail.com>
  obj-$(CONFIG_GPIO_RDA)                        += gpio-rda.o
 --- a/drivers/mtd/nand/raw/Kconfig
 +++ b/drivers/mtd/nand/raw/Kconfig
-@@ -563,4 +563,11 @@ config MTD_NAND_AR934X
+@@ -565,4 +565,11 @@ config MTD_NAND_AR934X
          Enables support for NAND controller on Qualcomm Atheros SoCs.
          This controller is found on AR934x and QCA955x SoCs.
  
@@ -111,9 +111,9 @@ Submitted-by: Christopher Hill <ch6574@gmail.com>
  endif # MTD_RAW_NAND
 --- a/drivers/mtd/nand/raw/Makefile
 +++ b/drivers/mtd/nand/raw/Makefile
-@@ -59,6 +59,7 @@ obj-$(CONFIG_MTD_NAND_INTEL_LGM)     += inte
- obj-$(CONFIG_MTD_NAND_ROCKCHIP)               += rockchip-nand-controller.o
+@@ -60,6 +60,7 @@ obj-$(CONFIG_MTD_NAND_ROCKCHIP)              += rock
  obj-$(CONFIG_MTD_NAND_PL35X)          += pl35x-nand-controller.o
+ obj-$(CONFIG_MTD_NAND_RENESAS)                += renesas-nand-controller.o
  obj-$(CONFIG_MTD_NAND_AR934X)         += ar934x_nand.o
 +obj-$(CONFIG_MTD_NAND_RB4XX)          += nand_rb4xx.o