bcm4908: remove 5.15 support
[openwrt/openwrt.git] / target / linux / bcm4908 / patches-5.15 / 040-v6.1-mtd-parsers-add-Broadcom-s-U-Boot-parser.patch
diff --git a/target/linux/bcm4908/patches-5.15/040-v6.1-mtd-parsers-add-Broadcom-s-U-Boot-parser.patch b/target/linux/bcm4908/patches-5.15/040-v6.1-mtd-parsers-add-Broadcom-s-U-Boot-parser.patch
deleted file mode 100644 (file)
index 4d4059b..0000000
+++ /dev/null
@@ -1,137 +0,0 @@
-From 002181f5b150e60c77f21de7ad4dd10e4614cd91 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Rafa=C5=82=20Mi=C5=82ecki?= <rafal@milecki.pl>
-Date: Mon, 11 Jul 2022 17:30:41 +0200
-Subject: [PATCH] mtd: parsers: add Broadcom's U-Boot parser
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Broadcom stores environment variables blocks inside U-Boot partition
-itself. This driver finds & registers them.
-
-Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
-Signed-off-by: Miquel Raynal <miquel.raynal@bootlin.com>
-Link: https://lore.kernel.org/linux-mtd/20220711153041.6036-2-zajec5@gmail.com
----
- drivers/mtd/parsers/Kconfig       | 10 ++++
- drivers/mtd/parsers/Makefile      |  1 +
- drivers/mtd/parsers/brcm_u-boot.c | 84 +++++++++++++++++++++++++++++++
- 3 files changed, 95 insertions(+)
- create mode 100644 drivers/mtd/parsers/brcm_u-boot.c
-
---- a/drivers/mtd/parsers/Kconfig
-+++ b/drivers/mtd/parsers/Kconfig
-@@ -20,6 +20,16 @@ config MTD_BCM63XX_PARTS
-         This provides partition parsing for BCM63xx devices with CFE
-         bootloaders.
-+config MTD_BRCM_U_BOOT
-+      tristate "Broadcom's U-Boot partition parser"
-+      depends on ARCH_BCM4908 || COMPILE_TEST
-+      help
-+        Broadcom uses a custom way of storing U-Boot environment variables.
-+        They are placed inside U-Boot partition itself at unspecified offset.
-+        It's possible to locate them by looking for a custom header with a
-+        magic value. This driver does that and creates subpartitions for
-+        each found environment variables block.
-+
- config MTD_CMDLINE_PARTS
-       tristate "Command line partition table parsing"
-       depends on MTD
---- a/drivers/mtd/parsers/Makefile
-+++ b/drivers/mtd/parsers/Makefile
-@@ -2,6 +2,7 @@
- obj-$(CONFIG_MTD_AR7_PARTS)           += ar7part.o
- obj-$(CONFIG_MTD_BCM47XX_PARTS)               += bcm47xxpart.o
- obj-$(CONFIG_MTD_BCM63XX_PARTS)               += bcm63xxpart.o
-+obj-$(CONFIG_MTD_BRCM_U_BOOT)         += brcm_u-boot.o
- obj-$(CONFIG_MTD_CMDLINE_PARTS)               += cmdlinepart.o
- obj-$(CONFIG_MTD_MYLOADER_PARTS)              += myloader.o
- obj-$(CONFIG_MTD_OF_PARTS)            += ofpart.o
---- /dev/null
-+++ b/drivers/mtd/parsers/brcm_u-boot.c
-@@ -0,0 +1,84 @@
-+// SPDX-License-Identifier: GPL-2.0-only
-+/*
-+ * Copyright © 2022 Rafał Miłecki <rafal@milecki.pl>
-+ */
-+
-+#include <linux/module.h>
-+#include <linux/kernel.h>
-+#include <linux/slab.h>
-+#include <linux/mtd/mtd.h>
-+#include <linux/mtd/partitions.h>
-+
-+#define BRCM_U_BOOT_MAX_OFFSET                0x200000
-+#define BRCM_U_BOOT_STEP              0x1000
-+
-+#define BRCM_U_BOOT_MAX_PARTS         2
-+
-+#define BRCM_U_BOOT_MAGIC             0x75456e76      /* uEnv */
-+
-+struct brcm_u_boot_header {
-+      __le32 magic;
-+      __le32 length;
-+} __packed;
-+
-+static const char *names[BRCM_U_BOOT_MAX_PARTS] = {
-+      "u-boot-env",
-+      "u-boot-env-backup",
-+};
-+
-+static int brcm_u_boot_parse(struct mtd_info *mtd,
-+                           const struct mtd_partition **pparts,
-+                           struct mtd_part_parser_data *data)
-+{
-+      struct brcm_u_boot_header header;
-+      struct mtd_partition *parts;
-+      size_t bytes_read;
-+      size_t offset;
-+      int err;
-+      int i = 0;
-+
-+      parts = kcalloc(BRCM_U_BOOT_MAX_PARTS, sizeof(*parts), GFP_KERNEL);
-+      if (!parts)
-+              return -ENOMEM;
-+
-+      for (offset = 0;
-+           offset < min_t(size_t, mtd->size, BRCM_U_BOOT_MAX_OFFSET);
-+           offset += BRCM_U_BOOT_STEP) {
-+              err = mtd_read(mtd, offset, sizeof(header), &bytes_read, (uint8_t *)&header);
-+              if (err && !mtd_is_bitflip(err)) {
-+                      pr_err("Failed to read from %s at 0x%zx: %d\n", mtd->name, offset, err);
-+                      continue;
-+              }
-+
-+              if (le32_to_cpu(header.magic) != BRCM_U_BOOT_MAGIC)
-+                      continue;
-+
-+              parts[i].name = names[i];
-+              parts[i].offset = offset;
-+              parts[i].size = sizeof(header) + le32_to_cpu(header.length);
-+              i++;
-+              pr_info("offset:0x%zx magic:0x%08x BINGO\n", offset, header.magic);
-+
-+              if (i == BRCM_U_BOOT_MAX_PARTS)
-+                      break;
-+      }
-+
-+      *pparts = parts;
-+
-+      return i;
-+};
-+
-+static const struct of_device_id brcm_u_boot_of_match_table[] = {
-+      { .compatible = "brcm,u-boot" },
-+      {},
-+};
-+MODULE_DEVICE_TABLE(of, brcm_u_boot_of_match_table);
-+
-+static struct mtd_part_parser brcm_u_boot_mtd_parser = {
-+      .parse_fn = brcm_u_boot_parse,
-+      .name = "brcm_u-boot",
-+      .of_match_table = brcm_u_boot_of_match_table,
-+};
-+module_mtd_part_parser(brcm_u_boot_mtd_parser);
-+
-+MODULE_LICENSE("GPL");