bcm53xx: switch to the kernel 5.10
[openwrt/openwrt.git] / target / linux / bcm53xx / Makefile
index 4171a04ee4c858607a7c3fd6b32a20dbd5db3439..083f9050967e9a138dd9060e018a8651f4bb7b73 100644 (file)
@@ -1,20 +1,18 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
 # Copyright (C) 2013 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+
 include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=bcm53xx
 BOARDNAME:=Broadcom BCM47xx/53xx (ARM)
-FEATURES:=squashfs nand usb pci pcie gpio
-MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
+FEATURES:=squashfs nand usb pci pcie gpio pwm
 CPU_TYPE:=cortex-a9
+SUBTARGETS:=generic
 
-KERNEL_PATCHVER:=4.14
-KERNEL_TESTING_PATCHVER := 4.19
+KERNEL_PATCHVER:=5.10
+KERNEL_TESTING_PATCHVER:=5.10
 
 define Target/Description
        Build firmware images for Broadcom based BCM47xx/53xx routers with ARM CPU, *not* MIPS.
@@ -27,6 +25,6 @@ KERNELNAME:=zImage dtbs
 DEFAULT_PACKAGES += swconfig nvram \
        osafeloader oseama otrx \
        kmod-gpio-button-hotplug \
-       kmod-leds-gpio kmod-ledtrig-default-on kmod-ledtrig-timer
+       kmod-leds-gpio
 
 $(eval $(call BuildTarget))