kernel: bump 4.9 to 4.9.57
[openwrt/openwrt.git] / target / linux / bcm53xx / Makefile
index 69f30f84ec99e220147dbebc10eb4cd51f5505db..30730ea47b5de6be3e5e1512a025114e8ce562bf 100644 (file)
@@ -12,19 +12,19 @@ BOARDNAME:=Broadcom BCM47xx/53xx (ARM)
 FEATURES:=squashfs nand usb pci pcie gpio
 MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
 CPU_TYPE:=cortex-a9
-CPU_SUBTYPE:=vfpv3
 
-LINUX_VERSION:=3.14.18
-
-include $(INCLUDE_DIR)/target.mk
+KERNEL_PATCHVER:=4.9
 
 define Target/Description
        Build firmware images for Broadcom based BCM47xx/53xx routers with ARM CPU, *not* MIPS.
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
 KERNELNAME:=zImage dtbs
 
-DEFAULT_PACKAGES += swconfig wpad-mini nvram \
+DEFAULT_PACKAGES += swconfig nvram \
+       osafeloader oseama otrx \
        kmod-gpio-button-hotplug \
        kmod-leds-gpio kmod-ledtrig-default-on kmod-ledtrig-timer