bcm53xx: switch to Kernel 5.15 by default
[openwrt/openwrt.git] / target / linux / bcm53xx / Makefile
index 2af1c7e719d6f55f244576cda1a2f01d5a9ae717..49d179c34c0ae8c1fac52d6d45f3edeb66c55d94 100644 (file)
@@ -1,19 +1,17 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
 # Copyright (C) 2013 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+
 include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=bcm53xx
 BOARDNAME:=Broadcom BCM47xx/53xx (ARM)
-FEATURES:=squashfs nand usb pci pcie gpio
-MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
+FEATURES:=squashfs nand usb pci pcie gpio pwm
 CPU_TYPE:=cortex-a9
+SUBTARGETS:=generic
 
-KERNEL_PATCHVER:=4.14
+KERNEL_PATCHVER:=5.15
 
 define Target/Description
        Build firmware images for Broadcom based BCM47xx/53xx routers with ARM CPU, *not* MIPS.
@@ -23,9 +21,9 @@ include $(INCLUDE_DIR)/target.mk
 
 KERNELNAME:=zImage dtbs
 
-DEFAULT_PACKAGES += swconfig nvram \
+DEFAULT_PACKAGES += nvram \
        osafeloader oseama otrx \
        kmod-gpio-button-hotplug \
-       kmod-leds-gpio kmod-ledtrig-default-on kmod-ledtrig-timer
+       kmod-leds-gpio
 
 $(eval $(call BuildTarget))