target: use SPDX license identifiers on Makefiles
[openwrt/staging/chunkeey.git] / target / linux / bcm53xx / Makefile
index 5b5e6077ac6117eaba92b8999a4cdc437087cd62..bb356ff244ee3b2bbc4b955bf0e6e3bdb9137f45 100644 (file)
@@ -1,30 +1,30 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
 # Copyright (C) 2013 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+
 include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=bcm53xx
 BOARDNAME:=Broadcom BCM47xx/53xx (ARM)
-FEATURES:=squashfs nand usb pci pcie gpio
-MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
+FEATURES:=squashfs nand usb pci pcie gpio pwm
 CPU_TYPE:=cortex-a9
+SUBTARGETS:=generic
 
-KERNEL_PATCHVER:=3.18
-
-include $(INCLUDE_DIR)/target.mk
+KERNEL_PATCHVER:=5.4
+KERNEL_TESTING_PATCHVER:=5.4
 
 define Target/Description
        Build firmware images for Broadcom based BCM47xx/53xx routers with ARM CPU, *not* MIPS.
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
 KERNELNAME:=zImage dtbs
 
-DEFAULT_PACKAGES += swconfig wpad-mini nvram \
+DEFAULT_PACKAGES += swconfig nvram \
+       osafeloader oseama otrx \
        kmod-gpio-button-hotplug \
-       kmod-leds-gpio kmod-ledtrig-default-on kmod-ledtrig-timer
+       kmod-leds-gpio
 
 $(eval $(call BuildTarget))