target: use SPDX license identifiers on Makefiles
[openwrt/staging/chunkeey.git] / target / linux / bcm53xx / Makefile
index 628d422b533dd5254e560c214fe25a0dda7bfaa5..bb356ff244ee3b2bbc4b955bf0e6e3bdb9137f45 100644 (file)
@@ -1,19 +1,17 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
 # Copyright (C) 2013 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+
 include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=bcm53xx
 BOARDNAME:=Broadcom BCM47xx/53xx (ARM)
-FEATURES:=squashfs nand usb pci pcie gpio
+FEATURES:=squashfs nand usb pci pcie gpio pwm
 CPU_TYPE:=cortex-a9
 SUBTARGETS:=generic
 
-KERNEL_PATCHVER:=4.19
+KERNEL_PATCHVER:=5.4
 KERNEL_TESTING_PATCHVER:=5.4
 
 define Target/Description
@@ -27,6 +25,6 @@ KERNELNAME:=zImage dtbs
 DEFAULT_PACKAGES += swconfig nvram \
        osafeloader oseama otrx \
        kmod-gpio-button-hotplug \
-       kmod-leds-gpio kmod-ledtrig-default-on kmod-ledtrig-timer
+       kmod-leds-gpio
 
 $(eval $(call BuildTarget))