bcm53xx: add nand flash driver
[openwrt/openwrt.git] / target / linux / bcm53xx / Makefile
index 69ca530dcb84eb8c8590091fc53b6f57375736ae..daad42b36938f74bbede5b1b25f0a530fdc194b1 100644 (file)
@@ -8,13 +8,12 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=bcm53xx
-BOARDNAME:=Broadcom BCM47xx/53xx with ARM CPU
-FEATURES:=squashfs usb pci pcie gpio
+BOARDNAME:=Broadcom BCM47xx/53xx (ARM)
+FEATURES:=squashfs nand usb pci pcie gpio
 MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
 CPU_TYPE:=cortex-a9
-CPU_SUBTYPE:=vfp
 
-LINUX_VERSION:=3.10.18
+LINUX_VERSION:=3.14.18
 
 include $(INCLUDE_DIR)/target.mk
 
@@ -24,6 +23,6 @@ endef
 
 KERNELNAME:="zImage dtbs"
 
-DEFAULT_PACKAGES += swconfig
+DEFAULT_PACKAGES += swconfig wpad-mini nvram
 
 $(eval $(call BuildTarget))