bcm53xx: backport DTS changes up to the first 4.15 queued commits
[openwrt/staging/hauke.git] / target / linux / bcm53xx / patches-4.9 / 035-v4.15-0003-ARM-dts-BCM5301X-Add-DT-for-Luxul-ABR-4500.patch
diff --git a/target/linux/bcm53xx/patches-4.9/035-v4.15-0003-ARM-dts-BCM5301X-Add-DT-for-Luxul-ABR-4500.patch b/target/linux/bcm53xx/patches-4.9/035-v4.15-0003-ARM-dts-BCM5301X-Add-DT-for-Luxul-ABR-4500.patch
new file mode 100644 (file)
index 0000000..71384a7
--- /dev/null
@@ -0,0 +1,96 @@
+From 65f78c4c41a9b9a7637e1dda2d5e41cf26ea971c Mon Sep 17 00:00:00 2001
+From: Dan Haab <dhaab@luxul.com>
+Date: Mon, 9 Oct 2017 09:46:23 -0600
+Subject: [PATCH] ARM: dts: BCM5301X: Add DT for Luxul ABR-4500
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+This is BCM47094 (AKA BCM4709C0) based router with rear-facing ports
+board design.
+
+Signed-off-by: Dan Haab <dhaab@luxul.com>
+Acked-by: Rafał Miłecki <rafal@milecki.pl>
+Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
+---
+ arch/arm/boot/dts/Makefile                    |  1 +
+ arch/arm/boot/dts/bcm47094-luxul-abr-4500.dts | 63 +++++++++++++++++++++++++++
+ 2 files changed, 64 insertions(+)
+ create mode 100644 arch/arm/boot/dts/bcm47094-luxul-abr-4500.dts
+
+--- a/arch/arm/boot/dts/Makefile
++++ b/arch/arm/boot/dts/Makefile
+@@ -95,6 +95,7 @@ dtb-$(CONFIG_ARCH_BCM_5301X) += \
+       bcm4709-tplink-archer-c9-v1.dtb \
+       bcm47094-dlink-dir-885l.dtb \
+       bcm47094-linksys-panamera.dtb \
++      bcm47094-luxul-abr-4500.dtb \
+       bcm47094-luxul-xbr-4500.dtb \
+       bcm47094-luxul-xwr-3100.dtb \
+       bcm47094-netgear-r8500.dtb \
+--- /dev/null
++++ b/arch/arm/boot/dts/bcm47094-luxul-abr-4500.dts
+@@ -0,0 +1,63 @@
++/*
++ * Copyright (C) 2017 Luxul Inc.
++ *
++ * Licensed under the ISC license.
++ */
++
++/dts-v1/;
++
++#include "bcm4708.dtsi"
++#include "bcm5301x-nand-cs0-bch8.dtsi"
++
++/ {
++      compatible = "luxul,abr-4500-v1", "brcm,bcm47094", "brcm,bcm4708";
++      model = "Luxul ABR-4500 V1";
++
++      chosen {
++              bootargs = "earlycon";
++      };
++
++      memory {
++              reg = <0x00000000 0x08000000
++                     0x88000000 0x18000000>;
++      };
++
++      leds {
++              compatible = "gpio-leds";
++
++              status {
++                      label = "bcm53xx:green:status";
++                      gpios = <&chipcommon 20 GPIO_ACTIVE_LOW>;
++                      linux,default-trigger = "timer";
++              };
++
++              usb3 {
++                      label = "bcm53xx:green:usb3";
++                      gpios = <&chipcommon 19 GPIO_ACTIVE_LOW>;
++                      trigger-sources = <&ohci_port1>, <&ehci_port1>,
++                              <&xhci_port1>;
++                      linux,default-trigger = "usbport";
++              };
++
++      };
++
++      gpio-keys {
++              compatible = "gpio-keys";
++              #address-cells = <1>;
++              #size-cells = <0>;
++
++              restart {
++                      label = "Reset";
++                      linux,code = <KEY_RESTART>;
++                      gpios = <&chipcommon 17 GPIO_ACTIVE_LOW>;
++              };
++      };
++};
++
++&usb3 {
++      vcc-gpio = <&chipcommon 18 GPIO_ACTIVE_HIGH>;
++};
++
++&spi_nor {
++      status = "okay";
++};