treewide: replace wpad-basic-wolfssl default
[openwrt/staging/stintel.git] / target / linux / bcm63xx / image / Makefile
index d8e68862b3206699ff93b20c6dedc9566e6f3f2b..9137971fa57e8a2f73ae55e2b1ab7b6f2385f11a 100644 (file)
@@ -1,10 +1,8 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
 # Copyright (C) 2006-2015 OpenWrt.org
 # Copyright (C) 2016 LEDE project
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
@@ -86,10 +84,6 @@ endef
 define rootfspad/squashfs
 endef
 
-define Image/LimitName16
-$(shell expr substr "$(1)" 1 16)
-endef
-
 define Image/FileSystemStrip
 $(firstword $(subst +,$(space),$(subst root.,,$(notdir $(1)))))
 endef
@@ -98,7 +92,7 @@ define Build/cfe-bin
        $(STAGING_DIR_HOST)/bin/imagetag -i $(IMAGE_KERNEL) -f $(IMAGE_ROOTFS) \
                --output $@ --boardid $(CFE_BOARD_ID) --chipid $(CHIP_ID) \
                --entry $(LOADER_ENTRY) --load-addr $(LOADER_ENTRY) \
-               --info1 "$(call Image/LimitName16,$(DEVICE_NAME))" \
+               --info1 "$(call ModelNameLimit16,$(DEVICE_NAME))" \
                --info2 "$(call Image/FileSystemStrip,$(IMAGE_ROOTFS))" \
                $(call rootfspad/$(call Image/FileSystemStrip,$(IMAGE_ROOTFS))) \
                $(CFE_EXTRAS) $(1)
@@ -311,12 +305,12 @@ define Device/Default
 endef
 DEVICE_VARS += CHIP_ID DEVICE_LOADADDR
 
-ATH5K_PACKAGES := kmod-ath5k wpad-basic-wolfssl
-ATH9K_PACKAGES := kmod-ath9k wpad-basic-wolfssl
-B43_PACKAGES := kmod-b43 wpad-basic-wolfssl
+ATH5K_PACKAGES := kmod-ath5k wpad-basic-mbedtls
+ATH9K_PACKAGES := kmod-ath9k wpad-basic-mbedtls
+B43_PACKAGES := kmod-b43 wpad-basic-mbedtls
 BRCMWL_PACKAGES := kmod-brcm-wl nas wlc
-RT28_PACKAGES := kmod-rt2800-pci wpad-basic-wolfssl
-RT61_PACKAGES := kmod-rt61-pci wpad-basic-wolfssl
+RT28_PACKAGES := kmod-rt2800-pci wpad-basic-mbedtls
+RT61_PACKAGES := kmod-rt61-pci wpad-basic-mbedtls
 USB1_PACKAGES := kmod-usb-ohci kmod-usb-ledtrig-usbport
 USB2_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-usb-ledtrig-usbport