base-files: sysupgrade: fix streaming backup archives to stdout
[openwrt/staging/stintel.git] / target / linux / bcm63xx / image / bcm63xx.mk
index 219eff5183f8630cb94bd186150623563c08efc6..9c5cc9bce5baf549f56e3bcd360c0bafec367dac 100644 (file)
@@ -19,7 +19,7 @@ endef
 
 define Device/bcm63xx
   FILESYSTEMS := squashfs jffs2-64k jffs2-128k
-  KERNEL := kernel-bin | append-dtb | relocate-kernel | lzma-cfe
+  KERNEL := kernel-bin | append-dtb | relocate-kernel | lzma
   KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma | loader-lzma elf
   IMAGES := cfe.bin
   IMAGE/cfe.bin := cfe-bin --pad $$$$(shell expr $$$$(FLASH_MB) / 2)
@@ -36,6 +36,11 @@ define Device/bcm63xx
   CFE_EXTRAS = --block-size $$(BLOCK_SIZE) --image-offset $$(if $$(IMAGE_OFFSET),$$(IMAGE_OFFSET),$$(BLOCK_SIZE))
 endef
 
+define Device/bcm63xx-legacy
+  $(Device/bcm63xx)
+  KERNEL := kernel-bin | append-dtb | relocate-kernel | lzma-cfe
+endef
+
 define Device/bcm63xx_netgear
   $(Device/bcm63xx)
   DEVICE_VENDOR := NETGEAR
@@ -51,7 +56,7 @@ define Device/bcm63xx_redboot
   KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma | loader-lzma elf
   IMAGES := redboot.bin
   IMAGE/redboot.bin := redboot-bin
-  REDBOOT_PREFIX := $$(IMAGE_PREFIX)
+  REDBOOT_PREFIX := $$(DEVICE_IMG_PREFIX)
 endef
 
 ### Generic ###
@@ -76,7 +81,7 @@ endef
 TARGET_DEVICES += brcm_bcm96328avng
 
 define Device/brcm_bcm96338gw
-  $(Device/bcm63xx)
+  $(Device/bcm63xx-legacy)
   DEVICE_VENDOR := Generic
   DEVICE_MODEL := 96338GW
   CFE_BOARD_ID := 6338GW
@@ -85,7 +90,7 @@ endef
 TARGET_DEVICES += brcm_bcm96338gw
 
 define Device/brcm_bcm96338w
-  $(Device/bcm63xx)
+  $(Device/bcm63xx-legacy)
   DEVICE_VENDOR := Generic
   DEVICE_MODEL := 96338W
   CFE_BOARD_ID := 6338W
@@ -95,7 +100,7 @@ endef
 TARGET_DEVICES += brcm_bcm96338w
 
 define Device/brcm_bcm96345gw2
-  $(Device/bcm63xx)
+  $(Device/bcm63xx-legacy)
   DEVICE_VENDOR := Generic
   DEVICE_MODEL := 96345GW2
   IMAGES += cfe-bc221.bin
@@ -106,7 +111,7 @@ endef
 TARGET_DEVICES += brcm_bcm96345gw2
 
 define Device/brcm_bcm96348gw
-  $(Device/bcm63xx)
+  $(Device/bcm63xx-legacy)
   DEVICE_VENDOR := Generic
   DEVICE_MODEL := 96348GW
   IMAGES += cfe-bc221.bin
@@ -117,7 +122,7 @@ endef
 TARGET_DEVICES += brcm_bcm96348gw
 
 define Device/brcm_bcm96348gw-10
-  $(Device/bcm63xx)
+  $(Device/bcm63xx-legacy)
   DEVICE_VENDOR := Generic
   DEVICE_MODEL := 96348GW-10
   CFE_BOARD_ID := 96348GW-10
@@ -127,7 +132,7 @@ endef
 TARGET_DEVICES += brcm_bcm96348gw-10
 
 define Device/brcm_bcm96348gw-11
-  $(Device/bcm63xx)
+  $(Device/bcm63xx-legacy)
   DEVICE_VENDOR := Generic
   DEVICE_MODEL := 96348GW-11
   CFE_BOARD_ID := 96348GW-11
@@ -137,7 +142,7 @@ endef
 TARGET_DEVICES += brcm_bcm96348gw-11
 
 define Device/brcm_bcm96348r
-  $(Device/bcm63xx)
+  $(Device/bcm63xx-legacy)
   DEVICE_VENDOR := Generic
   DEVICE_MODEL := 96348R
   CFE_BOARD_ID := 96348R
@@ -147,7 +152,7 @@ endef
 TARGET_DEVICES += brcm_bcm96348r
 
 define Device/brcm_bcm96358vw
-  $(Device/bcm63xx)
+  $(Device/bcm63xx-legacy)
   DEVICE_VENDOR := Generic
   DEVICE_MODEL := 96358VW
   CFE_BOARD_ID := 96358VW
@@ -156,7 +161,7 @@ endef
 TARGET_DEVICES += brcm_bcm96358vw
 
 define Device/brcm_bcm96358vw2
-  $(Device/bcm63xx)
+  $(Device/bcm63xx-legacy)
   DEVICE_VENDOR := Generic
   DEVICE_MODEL := 96358VW2
   CFE_BOARD_ID := 96358VW2
@@ -205,6 +210,7 @@ define Device/adb_a4001n
   CHIP_ID := 6328
   FLASH_MB := 8
   DEVICE_PACKAGES := $(USB2_PACKAGES) $(B43_PACKAGES)
+  DEFAULT := n
 endef
 TARGET_DEVICES += adb_a4001n
 
@@ -217,9 +223,35 @@ define Device/adb_a4001n1
   CHIP_ID := 6328
   FLASH_MB := 16
   DEVICE_PACKAGES := $(USB2_PACKAGES) $(B43_PACKAGES)
+  DEFAULT := n
 endef
 TARGET_DEVICES += adb_a4001n1
 
+define Device/adb_pdg-a4001n-a-000-1a1-ax
+  $(Device/bcm63xx)
+  DEVICE_VENDOR := ADB
+  DEVICE_MODEL := P.DG A4001N A-000-1A1-AX
+  IMAGES += sysupgrade.bin
+  CFE_BOARD_ID := 96328avng
+  CHIP_ID := 6328
+  FLASH_MB := 16
+  DEVICE_PACKAGES := $(USB2_PACKAGES) $(B43_PACKAGES)
+  DEFAULT := n
+endef
+TARGET_DEVICES += adb_pdg-a4001n-a-000-1a1-ax
+
+define Device/adb_pdg-a4101n-a-000-1a1-ae
+  $(Device/bcm63xx)
+  DEVICE_VENDOR := ADB
+  DEVICE_MODEL := P.DG A4101N A-000-1A1-AE
+  IMAGES += sysupgrade.bin
+  CFE_BOARD_ID := 96328avngv
+  CHIP_ID := 6328
+  FLASH_MB := 16
+  DEVICE_PACKAGES := $(USB2_PACKAGES) $(B43_PACKAGES)
+endef
+TARGET_DEVICES += adb_pdg-a4101n-a-000-1a1-ae
+
 define Device/adb_av4202n
   $(Device/bcm63xx)
   DEVICE_VENDOR := ADB
@@ -233,19 +265,20 @@ TARGET_DEVICES += adb_av4202n
 
 ### Alcatel ###
 define Device/alcatel_rg100a
-  $(Device/bcm63xx)
+  $(Device/bcm63xx-legacy)
   DEVICE_VENDOR := Alcatel
   DEVICE_MODEL := RG100A
   CFE_BOARD_ID := 96358VW2
   CHIP_ID := 6358
   BLOCK_SIZE := 0x20000
   DEVICE_PACKAGES := $(USB2_PACKAGES) $(B43_PACKAGES)
+  DEFAULT := n
 endef
 TARGET_DEVICES += alcatel_rg100a
 
 ### Asmax ###
 define Device/asmax_ar-1004g
-  $(Device/bcm63xx)
+  $(Device/bcm63xx-legacy)
   DEVICE_VENDOR := Asmax
   DEVICE_MODEL := AR 1004g
   CFE_BOARD_ID := 96348GW-10
@@ -257,7 +290,7 @@ TARGET_DEVICES += asmax_ar-1004g
 
 ### Belkin ###
 define Device/belkin_f5d7633
-  $(Device/bcm63xx)
+  $(Device/bcm63xx-legacy)
   DEVICE_VENDOR := Belkin
   DEVICE_MODEL := F5D7633
   CFE_BOARD_ID := 96348GW-10
@@ -316,8 +349,8 @@ TARGET_DEVICES += brcm_bcm963269bhr
 
 ### BT ###
 define Device/bt_home-hub-2-a
-  $(Device/bcm63xx)
-  DEVICE_VENDOR := BT
+  $(Device/bcm63xx-legacy)
+  DEVICE_VENDOR := British Telecom (BT)
   DEVICE_MODEL := Home Hub 2.0
   DEVICE_VARIANT := A
   CFE_BOARD_ID := HOMEHUB2A
@@ -328,8 +361,8 @@ endef
 TARGET_DEVICES += bt_home-hub-2-a
 
 define Device/bt_voyager-2110
-  $(Device/bcm63xx)
-  DEVICE_VENDOR := BT
+  $(Device/bcm63xx-legacy)
+  DEVICE_VENDOR := British Telecom (BT)
   DEVICE_MODEL := Voyager 2110
   CFE_BOARD_ID := V2110
   CHIP_ID := 6348
@@ -340,8 +373,8 @@ endef
 TARGET_DEVICES += bt_voyager-2110
 
 define Device/bt_voyager-2500v-bb
-  $(Device/bcm63xx)
-  DEVICE_VENDOR := BT
+  $(Device/bcm63xx-legacy)
+  DEVICE_VENDOR := British Telecom (BT)
   DEVICE_MODEL := Voyager 2500V
   CFE_BOARD_ID := V2500V_BB
   CHIP_ID := 6348
@@ -389,7 +422,7 @@ endef
 TARGET_DEVICES += comtrend_ar-5387un
 
 define Device/comtrend_ct-536plus
-  $(Device/bcm63xx)
+  $(Device/bcm63xx-legacy)
   DEVICE_VENDOR := Comtrend
   DEVICE_MODEL := CT-536+
   DEVICE_ALT0_VENDOR := Comtrend
@@ -402,7 +435,7 @@ endef
 TARGET_DEVICES += comtrend_ct-536plus
 
 define Device/comtrend_ct-5365
-  $(Device/bcm63xx)
+  $(Device/bcm63xx-legacy)
   DEVICE_VENDOR := Comtrend
   DEVICE_MODEL := CT-5365
   CFE_BOARD_ID := 96348A-122
@@ -413,12 +446,13 @@ endef
 TARGET_DEVICES += comtrend_ct-5365
 
 define Device/comtrend_ct-6373
-  $(Device/bcm63xx)
+  $(Device/bcm63xx-legacy)
   DEVICE_VENDOR := Comtrend
   DEVICE_MODEL := CT-6373
   CFE_BOARD_ID := CT6373-1
   CHIP_ID := 6358
   DEVICE_PACKAGES := $(B43_PACKAGES) $(USB2_PACKAGES)
+  DEFAULT := n
 endef
 TARGET_DEVICES += comtrend_ct-6373
 
@@ -471,7 +505,7 @@ TARGET_DEVICES += comtrend_wap-5813n
 
 ### D-Link ###
 define Device/d-link_dsl-2640b-b
-  $(Device/bcm63xx)
+  $(Device/bcm63xx-legacy)
   DEVICE_VENDOR := D-Link
   DEVICE_MODEL := DSL-2640B
   DEVICE_VARIANT := B2
@@ -483,7 +517,7 @@ endef
 TARGET_DEVICES += d-link_dsl-2640b-b
 
 define Device/d-link_dsl-2640u
-  $(Device/bcm63xx)
+  $(Device/bcm63xx-legacy)
   DEVICE_VENDOR := D-Link
   DEVICE_MODEL := DSL-2640U
   DEVICE_VARIANT := C1
@@ -497,17 +531,18 @@ endef
 TARGET_DEVICES += d-link_dsl-2640u
 
 define Device/d-link_dsl-2650u
-  $(Device/bcm63xx)
+  $(Device/bcm63xx-legacy)
   DEVICE_VENDOR := D-Link
   DEVICE_MODEL := DSL-2650U
   CFE_BOARD_ID := 96358VW2
   CHIP_ID := 6358
   DEVICE_PACKAGES := $(B43_PACKAGES) $(USB2_PACKAGES)
+  DEFAULT := n
 endef
 TARGET_DEVICES += d-link_dsl-2650u
 
 define Device/d-link_dsl-274xb-c2
-  $(Device/bcm63xx)
+  $(Device/bcm63xx-legacy)
   DEVICE_VENDOR := D-Link
   DEVICE_MODEL := DSL-2740B
   DEVICE_VARIANT := C2
@@ -522,7 +557,7 @@ endef
 TARGET_DEVICES += d-link_dsl-274xb-c2
 
 define Device/d-link_dsl-274xb-c3
-  $(Device/bcm63xx)
+  $(Device/bcm63xx-legacy)
   DEVICE_VENDOR := D-Link
   DEVICE_MODEL := DSL-2740B
   DEVICE_VARIANT := C3
@@ -554,6 +589,20 @@ define Device/d-link_dsl-274xb-f1
 endef
 TARGET_DEVICES += d-link_dsl-274xb-f1
 
+define Device/d-link_dsl-2750u-c1
+  $(Device/bcm63xx)
+  DEVICE_VENDOR := D-Link
+  DEVICE_MODEL := DSL-2750U
+  DEVICE_VARIANT := C1
+  IMAGES += sysupgrade.bin
+  CFE_BOARD_ID := 963281TAVNG
+  CHIP_ID := 6328
+  FLASH_MB := 8
+  DEVICE_PACKAGES := $(USB2_PACKAGES) $(B43_PACKAGES)
+  DEFAULT := n
+endef
+TARGET_DEVICES += d-link_dsl-2750u-c1
+
 define Device/d-link_dsl-275xb-d1
   $(Device/bcm63xx)
   DEVICE_VENDOR := D-Link
@@ -570,18 +619,19 @@ endef
 TARGET_DEVICES += d-link_dsl-275xb-d1
 
 define Device/d-link_dva-g3810bn-tl
-  $(Device/bcm63xx)
+  $(Device/bcm63xx-legacy)
   DEVICE_VENDOR := D-Link
   DEVICE_MODEL := DVA-G3810BN/TL
   CFE_BOARD_ID := 96358VW
   CHIP_ID := 6358
   DEVICE_PACKAGES := $(B43_PACKAGES) $(USB2_PACKAGES)
+  DEFAULT := n
 endef
 TARGET_DEVICES += d-link_dva-g3810bn-tl
 
 ### Davolink ###
 define Device/davolink_dv-201amr
-  $(Device/bcm63xx)
+  $(Device/bcm63xx-legacy)
   DEVICE_VENDOR := Davolink
   DEVICE_MODEL := DV-201AMR
   IMAGES := cfe-old.bin
@@ -594,7 +644,7 @@ TARGET_DEVICES += davolink_dv-201amr
 
 ### Dynalink ###
 define Device/dynalink_rta770bw
-  $(Device/bcm63xx)
+  $(Device/bcm63xx-legacy)
   DEVICE_VENDOR := Dynalink
   DEVICE_MODEL := RTA770BW
   DEVICE_ALT0_VENDOR := Siemens
@@ -609,7 +659,7 @@ endef
 TARGET_DEVICES += dynalink_rta770bw
 
 define Device/dynalink_rta770w
-  $(Device/bcm63xx)
+  $(Device/bcm63xx-legacy)
   DEVICE_VENDOR := Dynalink
   DEVICE_MODEL := RTA770W
   IMAGES =
@@ -622,7 +672,7 @@ endef
 TARGET_DEVICES += dynalink_rta770w
 
 define Device/dynalink_rta1025w
-  $(Device/bcm63xx)
+  $(Device/bcm63xx-legacy)
   DEVICE_VENDOR := Dynalink
   DEVICE_MODEL := RTA1025W
   CFE_BOARD_ID := RTA1025W_16
@@ -634,7 +684,7 @@ endef
 TARGET_DEVICES += dynalink_rta1025w
 
 define Device/dynalink_rta1320
-  $(Device/bcm63xx)
+  $(Device/bcm63xx-legacy)
   DEVICE_VENDOR := Dynalink
   DEVICE_MODEL := RTA1320
   CFE_BOARD_ID := RTA1320_16M
@@ -646,7 +696,7 @@ TARGET_DEVICES += dynalink_rta1320
 
 ### Huawei ###
 define Device/huawei_echolife-hg520v
-  $(Device/bcm63xx)
+  $(Device/bcm63xx-legacy)
   DEVICE_VENDOR := Huawei
   DEVICE_MODEL := EchoLife HG520v
   CFE_BOARD_ID := HW6358GW_B
@@ -659,7 +709,7 @@ endef
 TARGET_DEVICES += huawei_echolife-hg520v
 
 define Device/huawei_echolife-hg553
-  $(Device/bcm63xx)
+  $(Device/bcm63xx-legacy)
   DEVICE_VENDOR := Huawei
   DEVICE_MODEL := EchoLife HG553
   CFE_BOARD_ID := HW553
@@ -671,7 +721,7 @@ endef
 TARGET_DEVICES += huawei_echolife-hg553
 
 define Device/huawei_echolife-hg556a-a
-  $(Device/bcm63xx)
+  $(Device/bcm63xx-legacy)
   DEVICE_VENDOR := Huawei
   DEVICE_MODEL := EchoLife HG556a
   DEVICE_VARIANT := A
@@ -685,7 +735,7 @@ endef
 TARGET_DEVICES += huawei_echolife-hg556a-a
 
 define Device/huawei_echolife-hg556a-b
-  $(Device/bcm63xx)
+  $(Device/bcm63xx-legacy)
   DEVICE_VENDOR := Huawei
   DEVICE_MODEL := EchoLife HG556a
   DEVICE_VARIANT := B
@@ -699,7 +749,7 @@ endef
 TARGET_DEVICES += huawei_echolife-hg556a-b
 
 define Device/huawei_echolife-hg556a-c
-  $(Device/bcm63xx)
+  $(Device/bcm63xx-legacy)
   DEVICE_VENDOR := Huawei
   DEVICE_MODEL := EchoLife HG556a
   DEVICE_VARIANT := C
@@ -723,6 +773,7 @@ define Device/huawei_echolife-hg622
   BLOCK_SIZE := 0x20000
   FLASH_MB := 16
   DEVICE_PACKAGES := $(RT28_PACKAGES) $(USB2_PACKAGES)
+  DEFAULT := n
 endef
 TARGET_DEVICES += huawei_echolife-hg622
 
@@ -739,6 +790,18 @@ define Device/huawei_echolife-hg655b
 endef
 TARGET_DEVICES += huawei_echolife-hg655b
 
+### Innacomm ###
+define Device/innacomm_w3400v6
+  $(Device/bcm63xx)
+  DEVICE_VENDOR := Innacomm
+  DEVICE_MODEL := W3400V6
+  CFE_BOARD_ID := 96328ang
+  CHIP_ID := 6328
+  FLASH_MB := 8
+  DEVICE_PACKAGES := $(B43_PACKAGES)
+endef
+TARGET_DEVICES += innacomm_w3400v6
+
 ### Inteno ###
 define Device/inteno_vg50
   $(Device/bcm63xx)
@@ -771,11 +834,12 @@ define Device/netgear_cvg834g
   HCS_MAGIC_BYTES := 0xa020
   HCS_REV_MIN := 0001
   HCS_REV_MAJ := 0022
+  DEFAULT := n
 endef
 TARGET_DEVICES += netgear_cvg834g
 
 define Device/netgear_dg834gt-pn
-  $(Device/bcm63xx)
+  $(Device/bcm63xx-legacy)
   DEVICE_VENDOR := NETGEAR
   DEVICE_MODEL := DG834GT
   DEVICE_ALT0_VENDOR := NETGEAR
@@ -788,7 +852,7 @@ endef
 TARGET_DEVICES += netgear_dg834gt-pn
 
 define Device/netgear_dg834g-v4
-  $(Device/bcm63xx)
+  $(Device/bcm63xx-legacy)
   DEVICE_VENDOR := NETGEAR
   DEVICE_MODEL := DG834G
   DEVICE_VARIANT := v4
@@ -869,29 +933,31 @@ TARGET_DEVICES += observa_vh4032n
 
 ### Pirelli ###
 define Device/pirelli_a226g
-  $(Device/bcm63xx)
+  $(Device/bcm63xx-legacy)
   DEVICE_VENDOR := Pirelli
   DEVICE_MODEL := A226G
   CFE_BOARD_ID := DWV-S0
   CHIP_ID := 6358
   CFE_EXTRAS += --signature2 IMAGE --tag-version 8
   DEVICE_PACKAGES := $(B43_PACKAGES) $(USB2_PACKAGES)
+  DEFAULT := n
 endef
 TARGET_DEVICES += pirelli_a226g
 
 define Device/pirelli_a226m
-  $(Device/bcm63xx)
+  $(Device/bcm63xx-legacy)
   DEVICE_VENDOR := Pirelli
   DEVICE_MODEL := A226M
   CFE_BOARD_ID := DWV-S0
   CHIP_ID := 6358
   CFE_EXTRAS += --signature2 IMAGE --tag-version 8
   DEVICE_PACKAGES := $(USB2_PACKAGES)
+  DEFAULT := n
 endef
 TARGET_DEVICES += pirelli_a226m
 
 define Device/pirelli_a226m-fwb
-  $(Device/bcm63xx)
+  $(Device/bcm63xx-legacy)
   DEVICE_VENDOR := Pirelli
   DEVICE_MODEL := A226M-FWB
   CFE_BOARD_ID := DWV-S0
@@ -903,7 +969,7 @@ endef
 TARGET_DEVICES += pirelli_a226m-fwb
 
 define Device/pirelli_agpf-s0
-  $(Device/bcm63xx)
+  $(Device/bcm63xx-legacy)
   DEVICE_VENDOR := Pirelli
   DEVICE_MODEL := Alice Gate VoIP 2 Plus Wi-Fi AGPF-S0
   CFE_BOARD_ID := AGPF-S0
@@ -911,12 +977,13 @@ define Device/pirelli_agpf-s0
   CFE_EXTRAS += --signature2 IMAGE --tag-version 8
   BLOCK_SIZE := 0x20000
   DEVICE_PACKAGES := $(B43_PACKAGES) $(USB2_PACKAGES)
+  DEFAULT := n
 endef
 TARGET_DEVICES += pirelli_agpf-s0
 
 ### Sagem ###
 define Device/sagem_fast-2404
-  $(Device/bcm63xx)
+  $(Device/bcm63xx-legacy)
   DEVICE_VENDOR := Sagemcom
   DEVICE_MODEL := F@st 2404
   CFE_BOARD_ID := F@ST2404
@@ -937,7 +1004,7 @@ endef
 TARGET_DEVICES += sagem_fast-2504n
 
 define Device/sagem_fast-2604
-  $(Device/bcm63xx)
+  $(Device/bcm63xx-legacy)
   DEVICE_VENDOR := Sagemcom
   DEVICE_MODEL := F@st 2604
   CFE_BOARD_ID := F@ST2604
@@ -955,6 +1022,7 @@ define Device/sagem_fast-2704n
   CHIP_ID := 6318
   FLASH_MB := 8
   DEVICE_PACKAGES := $(B43_PACKAGES) $(USB2_PACKAGES)
+  DEFAULT := n
 endef
 TARGET_DEVICES += sagem_fast-2704n
 
@@ -984,7 +1052,7 @@ TARGET_DEVICES += sercomm_ad1018-nor
 
 ### SFR ###
 define Device/sfr_neufbox-4-sercomm-r0
-  $(Device/bcm63xx)
+  $(Device/bcm63xx-legacy)
   DEVICE_VENDOR := SFR
   DEVICE_MODEL := Neufbox 4
   DEVICE_VARIANT := Sercomm
@@ -992,11 +1060,12 @@ define Device/sfr_neufbox-4-sercomm-r0
   CHIP_ID := 6358
   CFE_EXTRAS += --rsa-signature "$(VERSION_DIST)-$(firstword $(subst -,$(space),$(REVISION)))"
   DEVICE_PACKAGES := $(B43_PACKAGES) $(USB2_PACKAGES)
+  DEFAULT := n
 endef
 TARGET_DEVICES += sfr_neufbox-4-sercomm-r0
 
 define Device/sfr_neufbox-4-foxconn-r1
-  $(Device/bcm63xx)
+  $(Device/bcm63xx-legacy)
   DEVICE_VENDOR := SFR
   DEVICE_MODEL := Neufbox 4
   DEVICE_VARIANT := Foxconn
@@ -1004,6 +1073,7 @@ define Device/sfr_neufbox-4-foxconn-r1
   CHIP_ID := 6358
   CFE_EXTRAS += --rsa-signature "$(VERSION_DIST)-$(firstword $(subst -,$(space),$(REVISION)))"
   DEVICE_PACKAGES := $(B43_PACKAGES) $(USB2_PACKAGES)
+  DEFAULT := n
 endef
 TARGET_DEVICES += sfr_neufbox-4-foxconn-r1
 
@@ -1033,7 +1103,7 @@ TARGET_DEVICES += sky_sr102
 
 ### T-Com ###
 define Device/t-com_speedport-w-303v
-  $(Device/bcm63xx)
+  $(Device/bcm63xx-legacy)
   DEVICE_VENDOR := T-Com
   DEVICE_MODEL := Speedport W 303V
   IMAGES := factory.bin sysupgrade.bin
@@ -1042,11 +1112,12 @@ define Device/t-com_speedport-w-303v
   CFE_BOARD_ID := 96358-502V
   CHIP_ID := 6358
   DEVICE_PACKAGES := $(B43_PACKAGES)
+  DEFAULT := n
 endef
 TARGET_DEVICES += t-com_speedport-w-303v
 
 define Device/t-com_speedport-w-500v
-  $(Device/bcm63xx)
+  $(Device/bcm63xx-legacy)
   DEVICE_VENDOR := T-Com
   DEVICE_MODEL := Speedport W 500V
   CFE_BOARD_ID := 96348GW
@@ -1056,9 +1127,35 @@ define Device/t-com_speedport-w-500v
 endef
 TARGET_DEVICES += t-com_speedport-w-500v
 
+### Technicolor ###
+define Device/technicolor_tg582n
+  $(Device/bcm63xx)
+  DEVICE_VENDOR := Technicolor
+  DEVICE_MODEL := TG582n
+  IMAGES += sysupgrade.bin
+  CFE_BOARD_ID := DANT-1
+  CHIP_ID := 6328
+  FLASH_MB := 16
+  DEVICE_PACKAGES := $(USB2_PACKAGES) $(B43_PACKAGES)
+endef
+TARGET_DEVICES += technicolor_tg582n
+
+define Device/technicolor_tg582n-telecom-italia
+  $(Device/bcm63xx)
+  DEVICE_VENDOR := Technicolor
+  DEVICE_MODEL := TG582n
+  DEVICE_VARIANT := Telecom Italia
+  IMAGES += sysupgrade.bin
+  CFE_BOARD_ID := DANT-V
+  CHIP_ID := 6328
+  FLASH_MB := 16
+  DEVICE_PACKAGES := $(USB2_PACKAGES) $(B43_PACKAGES)
+endef
+TARGET_DEVICES += technicolor_tg582n-telecom-italia
+
 ### Tecom ###
 define Device/tecom_gw6000
-  $(Device/bcm63xx)
+  $(Device/bcm63xx-legacy)
   DEVICE_VENDOR := Tecom
   DEVICE_MODEL := GW6000
   CFE_BOARD_ID := 96348GW
@@ -1069,7 +1166,7 @@ endef
 TARGET_DEVICES += tecom_gw6000
 
 define Device/tecom_gw6200
-  $(Device/bcm63xx)
+  $(Device/bcm63xx-legacy)
   DEVICE_VENDOR := Tecom
   DEVICE_MODEL := GW6200
   CFE_BOARD_ID := 96348GW
@@ -1082,7 +1179,7 @@ TARGET_DEVICES += tecom_gw6200
 
 ### Telsey ###
 define Device/telsey_cpva502plus
-  $(Device/bcm63xx)
+  $(Device/bcm63xx-legacy)
   DEVICE_VENDOR := Telsey
   DEVICE_MODEL := CPVA502+
   CFE_BOARD_ID := CPVA502+
@@ -1094,7 +1191,7 @@ endef
 TARGET_DEVICES += telsey_cpva502plus
 
 define Device/telsey_cpva642
-  $(Device/bcm63xx)
+  $(Device/bcm63xx-legacy)
   DEVICE_VENDOR := Telsey
   DEVICE_MODEL := CPVA642-type (CPA-ZNTE60T)
   CFE_BOARD_ID := CPVA642
@@ -1102,11 +1199,12 @@ define Device/telsey_cpva642
   CFE_EXTRAS += --signature "Telsey Tlc" --signature2 "99.99.999" --second-image-flag "0"
   FLASH_MB := 8
   DEVICE_PACKAGES := $(RT63_PACKAGES) $(USB2_PACKAGES)
+  DEFAULT := n
 endef
 TARGET_DEVICES += telsey_cpva642
 
 define Device/telsey_magic
-  $(Device/bcm63xx)
+  $(Device/bcm63xx-legacy)
   DEVICE_VENDOR := Alice
   DEVICE_MODEL := W-Gate
   DEVICE_ALT0_VENDOR := Telsey
@@ -1121,7 +1219,7 @@ TARGET_DEVICES += telsey_magic
 
 ### TP-Link ###
 define Device/tp-link_td-w8900gb
-  $(Device/bcm63xx)
+  $(Device/bcm63xx-legacy)
   DEVICE_VENDOR := TP-Link
   DEVICE_MODEL := TD-W8900GB
   CFE_BOARD_ID := 96348GW-11
@@ -1135,7 +1233,7 @@ TARGET_DEVICES += tp-link_td-w8900gb
 
 ### USRobotics ###
 define Device/usrobotics_usr9108
-  $(Device/bcm63xx)
+  $(Device/bcm63xx-legacy)
   DEVICE_VENDOR := USRobotics
   DEVICE_MODEL := USR9108
   CFE_BOARD_ID := 96348GW-A