Upgrade to Linux 2.6.19
[openwrt/staging/dedeckeh.git] / target / linux / brcm-2.6 / Makefile
index 178a2a79c215fb1ee7e0166c2797a0e4528daa90..162c45e86d91f4f8650c7641d2eed54773368e0b 100644 (file)
@@ -6,17 +6,37 @@
 #
 include $(TOPDIR)/rules.mk
 
-LINUX_VERSION:=2.6.17
+ARCH:=mipsel
+BOARD:=brcm
+BOARDNAME:=Broadcom BCM947xx/953xx
+FEATURES:=squashfs
+
+define Target/Description
+       Build firmware images for Broadcom based routers
+       (e.g. Linksys WRT54G(S), Asus WL-500g, Motorola WR850G)
+
+       This one builds the generic .trx images, activate one of the
+       options below for creating device specific files for use
+       with TFTP client too.
+endef
+
+LINUX_VERSION:=2.6.19
 LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=37ddefe96625502161f075b9d907f21e
+LINUX_KERNEL_MD5SUM:=443c265b57e87eadc0c677c3acc37e20
 
-include ./config
 include $(INCLUDE_DIR)/kernel-build.mk
+DEFAULT_PACKAGES += kmod-switch
 
+define Profile/Atheros
+  NAME:=Atheros WiFi (default)
+  PACKAGES:=kmod-madwifi
+endef
+$(eval $(call Profile,Atheros))
 
-$(LINUX_DIR)/.patched: $(LINUX_DIR)/.unpacked
-       [ -d ../generic-$(KERNEL)/patches ] && $(PATCH) $(LINUX_DIR) ../generic-$(KERNEL)/patches $(MAKE_TRACE)
-       [ -d ./patches ] && $(PATCH) $(LINUX_DIR) ./patches $(MAKE_TRACE)
-       @$(CP) config $(LINUX_DIR)/.config
-       touch $@
+define Profile/None
+  NAME:=No WiFi
+  PACKAGES:=
+endef
+$(eval $(call Profile,None))
 
+$(eval $(call BuildKernel))