brcm2708: rename target to bcm27xx
[openwrt/staging/chunkeey.git] / target / linux / brcm2708 / Makefile
diff --git a/target/linux/brcm2708/Makefile b/target/linux/brcm2708/Makefile
deleted file mode 100644 (file)
index d935758..0000000
+++ /dev/null
@@ -1,34 +0,0 @@
-#
-# Copyright (C) 2012-2019 OpenWrt.org
-# Copyright (C) 2017 LEDE project
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-include $(TOPDIR)/rules.mk
-
-ARCH:=arm
-BOARD:=brcm2708
-BOARDNAME:=Broadcom BCM27xx
-FEATURES:=ext4 audio usb usbgadget display gpio fpu squashfs rootfs-part boot-part
-MAINTAINER:=Álvaro Fernández Rojas <noltari@gmail.com>
-SUBTARGETS:=bcm2708 bcm2709 bcm2710 bcm2711
-
-KERNEL_PATCHVER:=4.19
-
-define Target/Description
-       Build firmware image for Broadcom BCM27xx SoC devices.
-       Currently produces SD Card image for Raspberry Pi.
-endef
-
-include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += \
-       brcm2708-gpu-fw \
-       kmod-usb-hid \
-       kmod-sound-core kmod-sound-arm-bcm2835 \
-       kmod-fs-vfat kmod-nls-cp437 kmod-nls-iso8859-1 \
-       partx-utils mkf2fs e2fsprogs
-
-KERNELNAME:=Image dtbs
-
-$(eval $(call BuildTarget))