brcm2708: update to latest patches from RPi Foundation
[openwrt/staging/chunkeey.git] / target / linux / brcm2708 / patches-4.19 / 950-0278-Added-driver-for-the-HiFiBerry-DAC-ADC-2694.patch
diff --git a/target/linux/brcm2708/patches-4.19/950-0278-Added-driver-for-the-HiFiBerry-DAC-ADC-2694.patch b/target/linux/brcm2708/patches-4.19/950-0278-Added-driver-for-the-HiFiBerry-DAC-ADC-2694.patch
deleted file mode 100644 (file)
index 9cd839e..0000000
+++ /dev/null
@@ -1,576 +0,0 @@
-From dde0ec6b9fd5755de3a8962489cde9c0ce5e5005 Mon Sep 17 00:00:00 2001
-From: HiFiBerry <info@hifiberry.com>
-Date: Mon, 8 Oct 2018 18:10:12 +0200
-Subject: [PATCH] Added driver for the HiFiBerry DAC+ ADC (#2694)
-
-Signed-off-by: Daniel Matuschek <daniel@hifiberry.com>
----
- arch/arm/boot/dts/overlays/Makefile           |   1 +
- arch/arm/boot/dts/overlays/README             |  21 +
- .../overlays/hifiberry-dacplusadc-overlay.dts |  71 +++
- sound/soc/bcm/Kconfig                         |   8 +
- sound/soc/bcm/Makefile                        |   2 +
- sound/soc/bcm/hifiberry_dacplusadc.c          | 407 ++++++++++++++++++
- 8 files changed, 512 insertions(+)
- create mode 100644 arch/arm/boot/dts/overlays/hifiberry-dacplusadc-overlay.dts
- create mode 100644 sound/soc/bcm/hifiberry_dacplusadc.c
-
---- a/arch/arm/boot/dts/overlays/Makefile
-+++ b/arch/arm/boot/dts/overlays/Makefile
-@@ -49,6 +49,7 @@ dtbo-$(CONFIG_ARCH_BCM2835) += \
-       hifiberry-amp.dtbo \
-       hifiberry-dac.dtbo \
-       hifiberry-dacplus.dtbo \
-+      hifiberry-dacplusadc.dtbo \
-       hifiberry-digi.dtbo \
-       hifiberry-digi-pro.dtbo \
-       hy28a.dtbo \
---- a/arch/arm/boot/dts/overlays/README
-+++ b/arch/arm/boot/dts/overlays/README
-@@ -779,6 +779,27 @@ Params: 24db_digital_gain       Allow ga
-                                 master for bit clock and frame clock.
-+Name:   hifiberry-dacplusadc
-+Info:   Configures the HifiBerry DAC+ADC audio card
-+Load:   dtoverlay=hifiberry-dacplusadc,<param>=<val>
-+Params: 24db_digital_gain       Allow gain to be applied via the PCM512x codec
-+                                Digital volume control. Enable with
-+                                "dtoverlay=hifiberry-dacplus,24db_digital_gain"
-+                                (The default behaviour is that the Digital
-+                                volume control is limited to a maximum of
-+                                0dB. ie. it can attenuate but not provide
-+                                gain. For most users, this will be desired
-+                                as it will prevent clipping. By appending
-+                                the 24dB_digital_gain parameter, the Digital
-+                                volume control will allow up to 24dB of
-+                                gain. If this parameter is enabled, it is the
-+                                responsibility of the user to ensure that
-+                                the Digital volume control is set to a value
-+                                that does not result in clipping/distortion!)
-+        slave                   Force DAC+ Pro into slave mode, using Pi as
-+                                master for bit clock and frame clock.
-+
-+
- Name:   hifiberry-digi
- Info:   Configures the HifiBerry Digi and Digi+ audio card
- Load:   dtoverlay=hifiberry-digi
---- /dev/null
-+++ b/arch/arm/boot/dts/overlays/hifiberry-dacplusadc-overlay.dts
-@@ -0,0 +1,71 @@
-+// Definitions for HiFiBerry DAC+ADC
-+/dts-v1/;
-+/plugin/;
-+
-+/ {
-+      compatible = "brcm,bcm2708";
-+
-+      fragment@0 {
-+              target-path = "/clocks";
-+              __overlay__ {
-+                      dacpro_osc: dacpro_osc {
-+                              compatible = "hifiberry,dacpro-clk";
-+                              #clock-cells = <0>;
-+                      };
-+              };
-+      };
-+
-+      fragment@1 {
-+              target = <&i2s>;
-+              __overlay__ {
-+                      status = "okay";
-+              };
-+      };
-+
-+      fragment@2 {
-+              target = <&i2c1>;
-+              __overlay__ {
-+                      #address-cells = <1>;
-+                      #size-cells = <0>;
-+                      status = "okay";
-+
-+                      pcm_codec: pcm5122@4d {
-+                              #sound-dai-cells = <0>;
-+                              compatible = "ti,pcm5122";
-+                              reg = <0x4d>;
-+                              clocks = <&dacpro_osc>;
-+                              AVDD-supply = <&vdd_3v3_reg>;
-+                              DVDD-supply = <&vdd_3v3_reg>;
-+                              CPVDD-supply = <&vdd_3v3_reg>;
-+                              status = "okay";
-+                      };
-+              };
-+      };
-+
-+      fragment@3 {
-+              target-path = "/";
-+              __overlay__ {
-+                      dmic {
-+                              #sound-dai-cells = <0>;
-+                              compatible = "dmic-codec";
-+                              num-channels = <2>;
-+                              status = "okay";
-+                      };
-+              };
-+      };
-+
-+      fragment@4 {
-+              target = <&sound>;
-+              hifiberry_dacplusadc: __overlay__ {
-+                      compatible = "hifiberry,hifiberry-dacplusadc";
-+                      i2s-controller = <&i2s>;
-+                      status = "okay";
-+              };
-+      };
-+
-+      __overrides__ {
-+              24db_digital_gain =
-+                      <&hifiberry_dacplusadc>,"hifiberry,24db_digital_gain?";
-+              slave = <&hifiberry_dacplusadc>,"hifiberry-dacplusadc,slave?";
-+      };
-+};
---- a/sound/soc/bcm/Kconfig
-+++ b/sound/soc/bcm/Kconfig
-@@ -46,6 +46,14 @@ config SND_BCM2708_SOC_HIFIBERRY_DACPLUS
-         help
-          Say Y or M if you want to add support for HifiBerry DAC+.
-+config SND_BCM2708_SOC_HIFIBERRY_DACPLUSADC
-+        tristate "Support for HifiBerry DAC+ADC"
-+        depends on SND_BCM2708_SOC_I2S || SND_BCM2835_SOC_I2S
-+        select SND_SOC_PCM512x_I2C
-+      select SND_SOC_DMIC
-+        help
-+         Say Y or M if you want to add support for HifiBerry DAC+ADC.
-+
- config SND_BCM2708_SOC_HIFIBERRY_DIGI
-         tristate "Support for HifiBerry Digi"
-         depends on SND_BCM2708_SOC_I2S || SND_BCM2835_SOC_I2S
---- a/sound/soc/bcm/Makefile
-+++ b/sound/soc/bcm/Makefile
-@@ -14,6 +14,7 @@ snd-soc-googlevoicehat-codec-objs := goo
- # BCM2708 Machine Support
- snd-soc-3dlab-nano-player-objs := 3dlab-nano-player.o
- snd-soc-hifiberry-dacplus-objs := hifiberry_dacplus.o
-+snd-soc-hifiberry-dacplusadc-objs := hifiberry_dacplusadc.o
- snd-soc-justboom-dac-objs := justboom-dac.o
- snd-soc-rpi-cirrus-objs := rpi-cirrus.o
- snd-soc-rpi-proto-objs := rpi-proto.o
-@@ -36,6 +37,7 @@ snd-soc-rpi-wm8804-soundcard-objs := rpi
- obj-$(CONFIG_SND_BCM2708_SOC_3DLAB_NANO_PLAYER) += snd-soc-3dlab-nano-player.o
- obj-$(CONFIG_SND_BCM2708_SOC_GOOGLEVOICEHAT_SOUNDCARD)  += snd-soc-googlevoicehat-codec.o
- obj-$(CONFIG_SND_BCM2708_SOC_HIFIBERRY_DACPLUS) += snd-soc-hifiberry-dacplus.o
-+obj-$(CONFIG_SND_BCM2708_SOC_HIFIBERRY_DACPLUSADC) += snd-soc-hifiberry-dacplusadc.o
- obj-$(CONFIG_SND_BCM2708_SOC_JUSTBOOM_DAC) += snd-soc-justboom-dac.o
- obj-$(CONFIG_SND_BCM2708_SOC_RPI_CIRRUS) += snd-soc-rpi-cirrus.o
- obj-$(CONFIG_SND_BCM2708_SOC_RPI_PROTO) += snd-soc-rpi-proto.o
---- /dev/null
-+++ b/sound/soc/bcm/hifiberry_dacplusadc.c
-@@ -0,0 +1,407 @@
-+/*
-+ * ASoC Driver for HiFiBerry DAC+ / DAC Pro with ADC
-+ *
-+ * Author:    Daniel Matuschek, Stuart MacLean <stuart@hifiberry.com>
-+ *            Copyright 2014-2015
-+ *            based on code by Florian Meier <florian.meier@koalo.de>
-+ *            ADC added by Joerg Schambacher <joscha@schambacher.com>
-+ *            Copyright 2018
-+ *
-+ * This program is free software; you can redistribute it and/or
-+ * modify it under the terms of the GNU General Public License
-+ * version 2 as published by the Free Software Foundation.
-+ *
-+ * This program is distributed in the hope that it will be useful, but
-+ * WITHOUT ANY WARRANTY; without even the implied warranty of
-+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
-+ * General Public License for more details.
-+ */
-+
-+#include <linux/module.h>
-+#include <linux/platform_device.h>
-+#include <linux/kernel.h>
-+#include <linux/clk.h>
-+#include <linux/kernel.h>
-+#include <linux/module.h>
-+#include <linux/of.h>
-+#include <linux/slab.h>
-+#include <linux/delay.h>
-+
-+#include <sound/core.h>
-+#include <sound/pcm.h>
-+#include <sound/pcm_params.h>
-+#include <sound/soc.h>
-+#include <sound/jack.h>
-+
-+#include "../codecs/pcm512x.h"
-+
-+#define HIFIBERRY_DACPRO_NOCLOCK 0
-+#define HIFIBERRY_DACPRO_CLK44EN 1
-+#define HIFIBERRY_DACPRO_CLK48EN 2
-+
-+struct platform_device *dmic_codec_dev;
-+
-+struct pcm512x_priv {
-+      struct regmap *regmap;
-+      struct clk *sclk;
-+};
-+
-+/* Clock rate of CLK44EN attached to GPIO6 pin */
-+#define CLK_44EN_RATE 22579200UL
-+/* Clock rate of CLK48EN attached to GPIO3 pin */
-+#define CLK_48EN_RATE 24576000UL
-+
-+static bool slave;
-+static bool snd_rpi_hifiberry_is_dacpro;
-+static bool digital_gain_0db_limit = true;
-+
-+static void snd_rpi_hifiberry_dacplusadc_select_clk(struct snd_soc_component *component,
-+      int clk_id)
-+{
-+      switch (clk_id) {
-+      case HIFIBERRY_DACPRO_NOCLOCK:
-+              snd_soc_component_update_bits(component, PCM512x_GPIO_CONTROL_1, 0x24, 0x00);
-+              break;
-+      case HIFIBERRY_DACPRO_CLK44EN:
-+              snd_soc_component_update_bits(component, PCM512x_GPIO_CONTROL_1, 0x24, 0x20);
-+              break;
-+      case HIFIBERRY_DACPRO_CLK48EN:
-+              snd_soc_component_update_bits(component, PCM512x_GPIO_CONTROL_1, 0x24, 0x04);
-+              break;
-+      }
-+}
-+
-+static void snd_rpi_hifiberry_dacplusadc_clk_gpio(struct snd_soc_component *component)
-+{
-+      snd_soc_component_update_bits(component, PCM512x_GPIO_EN, 0x24, 0x24);
-+      snd_soc_component_update_bits(component, PCM512x_GPIO_OUTPUT_3, 0x0f, 0x02);
-+      snd_soc_component_update_bits(component, PCM512x_GPIO_OUTPUT_6, 0x0f, 0x02);
-+}
-+
-+static bool snd_rpi_hifiberry_dacplusadc_is_sclk(struct snd_soc_component *component)
-+{
-+      unsigned int sck;
-+
-+      snd_soc_component_read(component, PCM512x_RATE_DET_4, &sck);
-+      return (!(sck & 0x40));
-+}
-+
-+static bool snd_rpi_hifiberry_dacplusadc_is_sclk_sleep(
-+      struct snd_soc_component *component)
-+{
-+      msleep(2);
-+      return snd_rpi_hifiberry_dacplusadc_is_sclk(component);
-+}
-+
-+static bool snd_rpi_hifiberry_dacplusadc_is_pro_card(struct snd_soc_component *component)
-+{
-+      bool isClk44EN, isClk48En, isNoClk;
-+
-+      snd_rpi_hifiberry_dacplusadc_clk_gpio(component);
-+
-+      snd_rpi_hifiberry_dacplusadc_select_clk(component, HIFIBERRY_DACPRO_CLK44EN);
-+      isClk44EN = snd_rpi_hifiberry_dacplusadc_is_sclk_sleep(component);
-+
-+      snd_rpi_hifiberry_dacplusadc_select_clk(component, HIFIBERRY_DACPRO_NOCLOCK);
-+      isNoClk = snd_rpi_hifiberry_dacplusadc_is_sclk_sleep(component);
-+
-+      snd_rpi_hifiberry_dacplusadc_select_clk(component, HIFIBERRY_DACPRO_CLK48EN);
-+      isClk48En = snd_rpi_hifiberry_dacplusadc_is_sclk_sleep(component);
-+
-+      return (isClk44EN && isClk48En && !isNoClk);
-+}
-+
-+static int snd_rpi_hifiberry_dacplusadc_clk_for_rate(int sample_rate)
-+{
-+      int type;
-+
-+      switch (sample_rate) {
-+      case 11025:
-+      case 22050:
-+      case 44100:
-+      case 88200:
-+      case 176400:
-+      case 352800:
-+              type = HIFIBERRY_DACPRO_CLK44EN;
-+              break;
-+      default:
-+              type = HIFIBERRY_DACPRO_CLK48EN;
-+              break;
-+      }
-+      return type;
-+}
-+
-+static void snd_rpi_hifiberry_dacplusadc_set_sclk(struct snd_soc_component *component,
-+      int sample_rate)
-+{
-+      struct pcm512x_priv *pcm512x = snd_soc_component_get_drvdata(component);
-+
-+      if (!IS_ERR(pcm512x->sclk)) {
-+              int ctype;
-+
-+              ctype = snd_rpi_hifiberry_dacplusadc_clk_for_rate(sample_rate);
-+              clk_set_rate(pcm512x->sclk, (ctype == HIFIBERRY_DACPRO_CLK44EN)
-+                      ? CLK_44EN_RATE : CLK_48EN_RATE);
-+              snd_rpi_hifiberry_dacplusadc_select_clk(component, ctype);
-+      }
-+}
-+
-+static int snd_rpi_hifiberry_dacplusadc_init(struct snd_soc_pcm_runtime *rtd)
-+{
-+      struct snd_soc_component *component = rtd->codec_dai->component;
-+      struct pcm512x_priv *priv;
-+
-+      if (slave)
-+              snd_rpi_hifiberry_is_dacpro = false;
-+      else
-+              snd_rpi_hifiberry_is_dacpro =
-+                              snd_rpi_hifiberry_dacplusadc_is_pro_card(component);
-+
-+      if (snd_rpi_hifiberry_is_dacpro) {
-+              struct snd_soc_dai_link *dai = rtd->dai_link;
-+
-+              dai->name = "HiFiBerry ADCDAC+ Pro";
-+              dai->stream_name = "HiFiBerry ADCDAC+ Pro HiFi";
-+              dai->dai_fmt = SND_SOC_DAIFMT_I2S | SND_SOC_DAIFMT_NB_NF
-+                      | SND_SOC_DAIFMT_CBM_CFM;
-+
-+              snd_soc_component_update_bits(component, PCM512x_BCLK_LRCLK_CFG, 0x31, 0x11);
-+              snd_soc_component_update_bits(component, PCM512x_MASTER_MODE, 0x03, 0x03);
-+              snd_soc_component_update_bits(component, PCM512x_MASTER_CLKDIV_2, 0x7f, 63);
-+      } else {
-+              priv = snd_soc_component_get_drvdata(component);
-+              priv->sclk = ERR_PTR(-ENOENT);
-+      }
-+
-+      snd_soc_component_update_bits(component, PCM512x_GPIO_EN, 0x08, 0x08);
-+      snd_soc_component_update_bits(component, PCM512x_GPIO_OUTPUT_4, 0x0f, 0x02);
-+      snd_soc_component_update_bits(component, PCM512x_GPIO_CONTROL_1, 0x08, 0x08);
-+
-+      if (digital_gain_0db_limit) {
-+              int ret;
-+              struct snd_soc_card *card = rtd->card;
-+
-+              ret = snd_soc_limit_volume(card, "Digital Playback Volume", 207);
-+              if (ret < 0)
-+                      dev_warn(card->dev, "Failed to set volume limit: %d\n", ret);
-+      }
-+
-+      return 0;
-+}
-+
-+static int snd_rpi_hifiberry_dacplusadc_update_rate_den(
-+      struct snd_pcm_substream *substream, struct snd_pcm_hw_params *params)
-+{
-+      struct snd_soc_pcm_runtime *rtd = substream->private_data;
-+      struct snd_soc_component *component = rtd->codec_dai->component;
-+      struct pcm512x_priv *pcm512x = snd_soc_component_get_drvdata(component);
-+      struct snd_ratnum *rats_no_pll;
-+      unsigned int num = 0, den = 0;
-+      int err;
-+
-+      rats_no_pll = devm_kzalloc(rtd->dev, sizeof(*rats_no_pll), GFP_KERNEL);
-+      if (!rats_no_pll)
-+              return -ENOMEM;
-+
-+      rats_no_pll->num = clk_get_rate(pcm512x->sclk) / 64;
-+      rats_no_pll->den_min = 1;
-+      rats_no_pll->den_max = 128;
-+      rats_no_pll->den_step = 1;
-+
-+      err = snd_interval_ratnum(hw_param_interval(params,
-+              SNDRV_PCM_HW_PARAM_RATE), 1, rats_no_pll, &num, &den);
-+      if (err >= 0 && den) {
-+              params->rate_num = num;
-+              params->rate_den = den;
-+      }
-+
-+      devm_kfree(rtd->dev, rats_no_pll);
-+      return 0;
-+}
-+
-+static int snd_rpi_hifiberry_dacplusadc_hw_params(
-+      struct snd_pcm_substream *substream, struct snd_pcm_hw_params *params)
-+{
-+      int ret = 0;
-+      struct snd_soc_pcm_runtime *rtd = substream->private_data;
-+      int channels = params_channels(params);
-+      int width = 32;
-+
-+      if (snd_rpi_hifiberry_is_dacpro) {
-+              struct snd_soc_component *component = rtd->codec_dai->component;
-+
-+              width = snd_pcm_format_physical_width(params_format(params));
-+
-+              snd_rpi_hifiberry_dacplusadc_set_sclk(component,
-+                      params_rate(params));
-+
-+              ret = snd_rpi_hifiberry_dacplusadc_update_rate_den(
-+                      substream, params);
-+      }
-+
-+      ret = snd_soc_dai_set_tdm_slot(rtd->cpu_dai, 0x03, 0x03,
-+              channels, width);
-+      if (ret)
-+              return ret;
-+      ret = snd_soc_dai_set_tdm_slot(rtd->codec_dai, 0x03, 0x03,
-+              channels, width);
-+      return ret;
-+}
-+
-+static int hifiberry_dacplusadc_LED_cnt;
-+
-+static int snd_rpi_hifiberry_dacplusadc_startup(
-+      struct snd_pcm_substream *substream)
-+{
-+      struct snd_soc_pcm_runtime *rtd = substream->private_data;
-+      struct snd_soc_component *component = rtd->codec_dai->component;
-+
-+      snd_soc_component_update_bits(component, PCM512x_GPIO_CONTROL_1,
-+                                       0x08, 0x08);
-+      hifiberry_dacplusadc_LED_cnt++;
-+      return 0;
-+}
-+
-+static void snd_rpi_hifiberry_dacplusadc_shutdown(
-+      struct snd_pcm_substream *substream)
-+{
-+      struct snd_soc_pcm_runtime *rtd = substream->private_data;
-+      struct snd_soc_component *component = rtd->codec_dai->component;
-+
-+      hifiberry_dacplusadc_LED_cnt--;
-+      if (!hifiberry_dacplusadc_LED_cnt)
-+              snd_soc_component_update_bits(component, PCM512x_GPIO_CONTROL_1,
-+                                               0x08, 0x00);
-+}
-+
-+/* machine stream operations */
-+static struct snd_soc_ops snd_rpi_hifiberry_dacplusadc_ops = {
-+      .hw_params = snd_rpi_hifiberry_dacplusadc_hw_params,
-+      .startup = snd_rpi_hifiberry_dacplusadc_startup,
-+      .shutdown = snd_rpi_hifiberry_dacplusadc_shutdown,
-+};
-+
-+static struct snd_soc_dai_link_component snd_rpi_hifiberry_dacplusadc_codecs[] = {
-+      {
-+              .name = "pcm512x.1-004d",
-+              .dai_name = "pcm512x-hifi",
-+      },
-+      {
-+              .name = "dmic-codec",
-+              .dai_name = "dmic-hifi",
-+      },
-+};
-+
-+static struct snd_soc_dai_link snd_rpi_hifiberry_dacplusadc_dai[] = {
-+{
-+      .name           = "HiFiBerry DAC+ADC",
-+      .stream_name    = "HiFiBerry DAC+ADC HiFi",
-+      .cpu_dai_name   = "bcm2708-i2s.0",
-+      .platform_name  = "bcm2708-i2s.0",
-+      .codecs         = snd_rpi_hifiberry_dacplusadc_codecs,
-+      .num_codecs     = 2,
-+      .dai_fmt        = SND_SOC_DAIFMT_I2S | SND_SOC_DAIFMT_NB_NF |
-+                              SND_SOC_DAIFMT_CBS_CFS,
-+      .ops            = &snd_rpi_hifiberry_dacplusadc_ops,
-+      .init           = snd_rpi_hifiberry_dacplusadc_init,
-+},
-+};
-+
-+/* audio machine driver */
-+static struct snd_soc_card snd_rpi_hifiberry_dacplusadc = {
-+      .name         = "snd_rpi_hifiberry_dacplusadc",
-+      .driver_name  = "HifiberryDacpAdc",
-+      .owner        = THIS_MODULE,
-+      .dai_link     = snd_rpi_hifiberry_dacplusadc_dai,
-+      .num_links    = ARRAY_SIZE(snd_rpi_hifiberry_dacplusadc_dai),
-+};
-+
-+
-+static int snd_rpi_hifiberry_dacplusadc_probe(struct platform_device *pdev)
-+{
-+      int ret = 0;
-+
-+      snd_rpi_hifiberry_dacplusadc.dev = &pdev->dev;
-+      if (pdev->dev.of_node) {
-+              struct device_node *i2s_node;
-+              struct snd_soc_dai_link *dai;
-+
-+              dai = &snd_rpi_hifiberry_dacplusadc_dai[0];
-+              i2s_node = of_parse_phandle(pdev->dev.of_node,
-+                      "i2s-controller", 0);
-+              if (i2s_node) {
-+                      dai->cpu_of_node = i2s_node;
-+                      dai->platform_of_node = i2s_node;
-+                      dai->cpu_dai_name = NULL;
-+                      dai->platform_name = NULL;
-+              }
-+              dai = &snd_rpi_hifiberry_dacplusadc_dai[1];
-+              i2s_node = of_parse_phandle(pdev->dev.of_node, "dmic", 0);
-+              if (i2s_node) {
-+                      dai->cpu_of_node = i2s_node;
-+                      dai->platform_of_node = i2s_node;
-+              }
-+
-+      }
-+      digital_gain_0db_limit = !of_property_read_bool(
-+              pdev->dev.of_node, "hifiberry,24db_digital_gain");
-+      slave = of_property_read_bool(pdev->dev.of_node,
-+                                      "hifiberry-dacplusadc,slave");
-+
-+      ret = devm_snd_soc_register_card(&pdev->dev,
-+                                               &snd_rpi_hifiberry_dacplusadc);
-+      if (ret && ret != -EPROBE_DEFER)
-+              dev_err(&pdev->dev,
-+                      "snd_soc_register_card() failed: %d\n", ret);
-+
-+      return ret;
-+}
-+
-+static const struct of_device_id snd_rpi_hifiberry_dacplusadc_of_match[] = {
-+      { .compatible = "hifiberry,hifiberry-dacplusadc", },
-+      {},
-+};
-+
-+MODULE_DEVICE_TABLE(of, snd_rpi_hifiberry_dacplusadc_of_match);
-+
-+static struct platform_driver snd_rpi_hifiberry_dacplusadc_driver = {
-+      .driver = {
-+              .name   = "snd-rpi-hifiberry-dacplusadc",
-+              .owner  = THIS_MODULE,
-+              .of_match_table = snd_rpi_hifiberry_dacplusadc_of_match,
-+      },
-+      .probe          = snd_rpi_hifiberry_dacplusadc_probe,
-+};
-+
-+static int __init hifiberry_dacplusadc_init(void)
-+{
-+      int ret;
-+
-+      dmic_codec_dev = platform_device_register_simple("dmic-codec", -1, NULL,
-+                                                       0);
-+      if (IS_ERR(dmic_codec_dev)) {
-+              pr_err("%s: dmic-codec device registration failed\n", __func__);
-+              return PTR_ERR(dmic_codec_dev);
-+      }
-+
-+      ret = platform_driver_register(&snd_rpi_hifiberry_dacplusadc_driver);
-+      if (ret) {
-+              pr_err("%s: platform driver registration failed\n", __func__);
-+              platform_device_unregister(dmic_codec_dev);
-+      }
-+
-+      return ret;
-+}
-+module_init(hifiberry_dacplusadc_init);
-+
-+static void __exit hifiberry_dacplusadc_exit(void)
-+{
-+      platform_driver_unregister(&snd_rpi_hifiberry_dacplusadc_driver);
-+      platform_device_unregister(dmic_codec_dev);
-+}
-+module_exit(hifiberry_dacplusadc_exit);
-+
-+MODULE_AUTHOR("Joerg Schambacher <joscha@schambacher.com>");
-+MODULE_AUTHOR("Daniel Matuschek <daniel@hifiberry.com>");
-+MODULE_DESCRIPTION("ASoC Driver for HiFiBerry DAC+ADC");
-+MODULE_LICENSE("GPL v2");