brcm2708: update to latest patches from RPi foundation
[openwrt/openwrt.git] / target / linux / brcm2708 / patches-4.19 / 950-0806-ARM-dts-Remove-bcm2838-rpi-4-b.dts.patch
diff --git a/target/linux/brcm2708/patches-4.19/950-0806-ARM-dts-Remove-bcm2838-rpi-4-b.dts.patch b/target/linux/brcm2708/patches-4.19/950-0806-ARM-dts-Remove-bcm2838-rpi-4-b.dts.patch
new file mode 100644 (file)
index 0000000..7a0b8c5
--- /dev/null
@@ -0,0 +1,146 @@
+From 8aa8fd89094952e3201b927fb846ba61b30cab6b Mon Sep 17 00:00:00 2001
+From: Phil Elwell <phil@raspberrypi.org>
+Date: Wed, 29 Jan 2020 11:29:06 +0000
+Subject: [PATCH] ARM: dts: Remove bcm2838-rpi-4-b.dts
+
+Upstream are not going to use the bcm2838 identifier, so begin the
+cleanup by removing the suggested upstream Pi 4 .dts file.
+
+Signed-off-by: Phil Elwell <phil@raspberrypi.org>
+---
+ arch/arm/boot/dts/Makefile            |   1 -
+ arch/arm/boot/dts/bcm2838-rpi-4-b.dts | 118 --------------------------
+ 2 files changed, 119 deletions(-)
+ delete mode 100644 arch/arm/boot/dts/bcm2838-rpi-4-b.dts
+
+--- a/arch/arm/boot/dts/Makefile
++++ b/arch/arm/boot/dts/Makefile
+@@ -95,7 +95,6 @@ dtb-$(CONFIG_ARCH_BCM2835) += \
+       bcm2836-rpi-2-b.dtb \
+       bcm2837-rpi-3-b.dtb \
+       bcm2837-rpi-3-b-plus.dtb \
+-      bcm2838-rpi-4-b.dtb \
+       bcm2835-rpi-zero.dtb \
+       bcm2835-rpi-zero-w.dtb
+ dtb-$(CONFIG_ARCH_BCM_5301X) += \
+--- a/arch/arm/boot/dts/bcm2838-rpi-4-b.dts
++++ /dev/null
+@@ -1,118 +0,0 @@
+-// SPDX-License-Identifier: GPL-2.0
+-/dts-v1/;
+-#include "bcm2838.dtsi"
+-#include "bcm2835-rpi.dtsi"
+-#include "bcm2838-rpi.dtsi"
+-
+-/ {
+-      compatible = "raspberrypi,4-model-b", "brcm,bcm2711";
+-      model = "Raspberry Pi 4 Model B";
+-
+-      chosen {
+-              /* 8250 auxiliary UART instead of pl011 */
+-              stdout-path = "serial1:115200n8";
+-      };
+-
+-      memory@0 {
+-              reg = <0 0 0x40000000>;
+-      };
+-
+-      leds {
+-              act {
+-                      gpios = <&gpio 42 GPIO_ACTIVE_HIGH>;
+-              };
+-
+-              pwr {
+-                      label = "PWR";
+-                      gpios = <&expgpio 2 GPIO_ACTIVE_LOW>;
+-              };
+-      };
+-
+-      wifi_pwrseq: wifi-pwrseq {
+-              compatible = "mmc-pwrseq-simple";
+-              reset-gpios = <&expgpio 1 GPIO_ACTIVE_LOW>;
+-      };
+-
+-      sd_io_1v8_reg: sd_io_1v8_reg {
+-              status = "okay";
+-              compatible = "regulator-gpio";
+-              vin-supply = <&vdd_5v0_reg>;
+-              regulator-name = "vdd-sd-io";
+-              regulator-min-microvolt = <1800000>;
+-              regulator-max-microvolt = <3300000>;
+-              regulator-boot-on;
+-              regulator-always-on;
+-              regulator-settling-time-us = <5000>;
+-
+-              gpios = <&expgpio 4 GPIO_ACTIVE_HIGH>;
+-              states = <1800000 0x1
+-                        3300000 0x0>;
+-      };
+-};
+-
+-&firmware {
+-      expgpio: gpio {
+-              compatible = "raspberrypi,firmware-gpio";
+-              gpio-controller;
+-              #gpio-cells = <2>;
+-              gpio-line-names = "BT_ON",
+-                                "WL_ON",
+-                                "PWR_LED_OFF",
+-                                "GLOBAL_RESET",
+-                                "VDD_SD_IO_SEL",
+-                                "CAM_GPIO",
+-                                "",
+-                                "";
+-              status = "okay";
+-      };
+-};
+-
+-&pwm1 {
+-      pinctrl-names = "default";
+-      pinctrl-0 = <&pwm0_gpio40 &pwm1_gpio41>;
+-      status = "okay";
+-};
+-
+-/* SDHCI is used to control the SDIO for wireless */
+-&sdhci {
+-      #address-cells = <1>;
+-      #size-cells = <0>;
+-      pinctrl-names = "default";
+-      pinctrl-0 = <&emmc_gpio34>;
+-      status = "okay";
+-      bus-width = <4>;
+-      non-removable;
+-      mmc-pwrseq = <&wifi_pwrseq>;
+-
+-      brcmf: wifi@1 {
+-              reg = <1>;
+-              compatible = "brcm,bcm4329-fmac";
+-      };
+-};
+-
+-/* EMMC2 is used to drive the SD card */
+-&emmc2 {
+-      status = "okay";
+-      broken-cd;
+-      vqmmc-supply = <&sd_io_1v8_reg>;
+-};
+-
+-/* uart0 communicates with the BT module */
+-&uart0 {
+-      pinctrl-names = "default";
+-      pinctrl-0 = <&uart0_ctsrts_gpio30 &uart0_gpio32 &gpclk2_gpio43>;
+-      status = "okay";
+-
+-      bluetooth {
+-              compatible = "brcm,bcm43438-bt";
+-              max-speed = <2000000>;
+-              shutdown-gpios = <&expgpio 0 GPIO_ACTIVE_HIGH>;
+-      };
+-};
+-
+-/* uart1 is mapped to the pin header */
+-&uart1 {
+-      pinctrl-names = "default";
+-      pinctrl-0 = <&uart1_gpio14>;
+-      status = "okay";
+-};