brcm47xx: change generic profiles
[openwrt/svn-archive/archive.git] / target / linux / brcm47xx / profiles / 104-Broadcom-ath5k.mk
index 56a505a90e55ce53d3f809e986d4f5e12e2a9e10..cd6b10b373737444028dbb7115610f8a81b68afb 100644 (file)
@@ -1,18 +1,19 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 
 define Profile/Broadcom-ath5k
-  NAME:=Atheros WiFi (ath5k)
-  PACKAGES:=kmod-b44 kmod-ath5k
+  NAME:=Broadcom SoC, all Ethernet, Atheros WiFi (ath5k)
+  PACKAGES:=kmod-b44 kmod-tg3 kmod-bgmac kmod-ath5k
 endef
 
-define Profile/Atheros/Description
-       Package set compatible with hardware using Atheros WiFi cards and
-       b44 Ethernet driver.
+define Profile/Broadcom-ath5k/Description
+       Package set compatible with hardware any Broadcom BCM47xx or BCM535x 
+       SoC with Atheros Wifi cards using the mac80211 and ath5k drivers and 
+       b44, tg3 or bgmac Ethernet driver.
 endef
 $(eval $(call Profile,Broadcom-ath5k))