brcm47xx: change generic profiles
[openwrt/svn-archive/archive.git] / target / linux / brcm47xx / profiles / 211-Broadcom-tg3-wl.mk
diff --git a/target/linux/brcm47xx/profiles/211-Broadcom-tg3-wl.mk b/target/linux/brcm47xx/profiles/211-Broadcom-tg3-wl.mk
new file mode 100644 (file)
index 0000000..d2788e6
--- /dev/null
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2010-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-tg3-wl
+  NAME:=Broadcom SoC, tg3 Ethernet, BCM43xx WiFi (wl, proprietary)
+  PACKAGES:=-wpad-mini kmod-brcm-wl wlc nas kmod-tg3
+endef
+
+define Profile/Broadcom-tg3-wl/Description
+       Package set compatible with hardware Broadcom BCM4705/BCM4785
+       SoC with Broadcom BCM43xx Wifi cards using the proprietary Broadcom 
+       wireless "wl" driver and tg3 Ethernet driver.
+endef
+
+$(eval $(call Profile,Broadcom-tg3-wl))
+