update work in progress rewritten bcm947xx code. wifi and usb seem to be working...
[openwrt/svn-archive/archive.git] / target / linux / brcm47xx-2.6 / files / drivers / ssb / Makefile
diff --git a/target/linux/brcm47xx-2.6/files/drivers/ssb/Makefile b/target/linux/brcm47xx-2.6/files/drivers/ssb/Makefile
new file mode 100644 (file)
index 0000000..9f85d22
--- /dev/null
@@ -0,0 +1,14 @@
+ssb-driver-chipcommon-y                                := driver_chipcommon/chipcommon.o
+ssb-driver-mips-$(CONFIG_BCM947XX)     := driver_mips/mips.o
+ssb-driver-pci-$(CONFIG_SSB_DRIVER_PCICORE)    := driver_pci/pcicore.o
+
+ssb-$(CONFIG_SSB_PCIHOST)                      += pci.o
+ssb-$(CONFIG_SSB_PCMCIAHOST)                   += pcmcia.o
+
+obj-$(CONFIG_SSB) += ssb.o
+
+ssb-objs       := core.o scan.o \
+                  $(ssb-y) $(ssb-m) \
+                  $(ssb-driver-chipcommon-y) \
+                  $(ssb-driver-mips-y) \
+                  $(ssb-driver-pci-y)