kernel: update to kernel 3.9.10 and refresh patches
[openwrt/staging/yousong.git] / target / linux / brcm63xx / Makefile
index 33c0268787a89d4e21119802d8fb61cb4bd493b0..c2cbdf6c3671167d0a684e27b47302c058ca48c4 100644 (file)
@@ -9,14 +9,14 @@ include $(TOPDIR)/rules.mk
 ARCH:=mips
 BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM63xx
-FEATURES:=squashfs jffs2 usb atm pci pcmcia
-LINUX_VERSION:=2.6.39.4
+SUBTARGETS:=generic smp
+FEATURES:=squashfs usb atm pci pcmcia
+LINUX_VERSION:=3.9.10
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += kmod-switch gpioctl kmod-input-gpio-buttons \
-       kmod-button-hotplug
+DEFAULT_PACKAGES += swconfig kmod-input-gpio-keys-polled kmod-button-hotplug
 
 define Target/Description
        Build firmware images for Broadcom based xDSL/routers