brcm63xx: Use leds script for Huawei HG556a and improve profile
[openwrt/staging/wigyori.git] / target / linux / brcm63xx / generic / profiles / 201-Huawei.mk
index 3cdd018ace7db8fe8f41d9c2482c132121848e9e..820f5e096ce639c8792dbd96e6ea7fbf8ae4be4a 100644 (file)
@@ -16,11 +16,11 @@ endef
 $(eval $(call Profile,HW553))
 
 define Profile/HW556
-  NAME:=HW556 WiFi
-  PACKAGES:=kmod-rt2800-pci kmod-ath9k wpad-mini
+  NAME:=Huawei HG556a
+  PACKAGES:=kmod-rt2800-pci kmod-ath9k wpad-mini \
+       kmod-usb2 kmod-usb-ohci kmod-ledtrig-usbdev
 endef
-
 define Profile/HW556/Description
-       Package set compatible with hardware using Atheros or Ralink WiFi cards (Huawei HG556a)
+       Package set optimized for Huawei HG556a using open-source atheros or ralink WiFi driver
 endef
 $(eval $(call Profile,HW556))