[kernel] remove no longer used configs and patches
[openwrt/svn-archive/archive.git] / target / linux / brcm63xx / patches-2.6.27 / 010-add_integrated_ethernet_phy_support.patch
diff --git a/target/linux/brcm63xx/patches-2.6.27/010-add_integrated_ethernet_phy_support.patch b/target/linux/brcm63xx/patches-2.6.27/010-add_integrated_ethernet_phy_support.patch
deleted file mode 100644 (file)
index b2eace1..0000000
+++ /dev/null
@@ -1,38 +0,0 @@
-From 7eefcb968019804e024c8243e28afb1eebd674a2 Mon Sep 17 00:00:00 2001
-From: Maxime Bizon <mbizon@freebox.fr>
-Date: Sun, 21 Sep 2008 02:20:53 +0200
-Subject: [PATCH] [MIPS] BCM63XX: Add integrated ethernet PHY support for phylib.
-
-Signed-off-by: Maxime Bizon <mbizon@freebox.fr>
----
- drivers/net/phy/Kconfig   |    6 ++
- drivers/net/phy/Makefile  |    1 +
- drivers/net/phy/bcm63xx.c |  132 +++++++++++++++++++++++++++++++++++++++++++++
- 3 files changed, 139 insertions(+), 0 deletions(-)
- create mode 100644 drivers/net/phy/bcm63xx.c
-
---- a/drivers/net/phy/Kconfig
-+++ b/drivers/net/phy/Kconfig
-@@ -62,6 +62,12 @@ config BROADCOM_PHY
-         Currently supports the BCM5411, BCM5421, BCM5461, BCM5464, BCM5481
-         and BCM5482 PHYs.
-+config BCM63XX_PHY
-+      tristate "Drivers for Broadcom 63xx SOCs internal PHY"
-+      depends on BCM63XX
-+      ---help---
-+        Currently supports the 6348 and 6358 PHYs.
-+
- config ICPLUS_PHY
-       tristate "Drivers for ICPlus PHYs"
-       ---help---
---- a/drivers/net/phy/Makefile
-+++ b/drivers/net/phy/Makefile
-@@ -12,6 +12,7 @@ obj-$(CONFIG_QSEMI_PHY)              += qsemi.o
- obj-$(CONFIG_SMSC_PHY)                += smsc.o
- obj-$(CONFIG_VITESSE_PHY)     += vitesse.o
- obj-$(CONFIG_BROADCOM_PHY)    += broadcom.o
-+obj-$(CONFIG_BCM63XX_PHY)     += bcm63xx.o
- obj-$(CONFIG_ICPLUS_PHY)      += icplus.o
- obj-$(CONFIG_ADM6996_PHY)     += adm6996.o
- obj-$(CONFIG_MVSWITCH_PHY)    += mvswitch.o