brcm63xx: add profiles for DTB supported devices
[openwrt/svn-archive/archive.git] / target / linux / brcm63xx / profiles / huawei.mk
diff --git a/target/linux/brcm63xx/profiles/huawei.mk b/target/linux/brcm63xx/profiles/huawei.mk
new file mode 100644 (file)
index 0000000..b0775c1
--- /dev/null
@@ -0,0 +1,26 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/HG556a_AB
+  NAME:=Huawei EchoLife HG556a (version A/B - Atheros)
+  PACKAGES:=kmod-ath9k wpad-mini \
+       kmod-usb2 kmod-usb-ohci kmod-ledtrig-usbdev
+endef
+define Profile/HG556a_AB/Description
+  Package set optimized for Huawei HG556a version A/B (Atheros).
+endef
+$(eval $(call Profile,HG556a_AB))
+
+define Profile/HG556a_C
+  NAME:=Huawei EchoLife HG556a (version C - Ralink)
+  PACKAGES:=kmod-rt2800-pci wpad-mini \
+       kmod-usb2 kmod-usb-ohci kmod-ledtrig-usbdev
+endef
+define Profile/HG556a_C/Description
+  Package set optimized for Huawei HG556a version C (Ralink).
+endef
+$(eval $(call Profile,HG556a_C))