treewide: use wpad-basic-wolfssl as default
[openwrt/staging/dedeckeh.git] / target / linux / cns3xxx / Makefile
index 7105c45ea1bec23ffc182a85c206a214fee14d5e..04df322b64c9f02a625b0247cc19b81e158882ae 100644 (file)
@@ -12,19 +12,17 @@ BOARDNAME:=Cavium Networks Econa CNS3xxx
 FEATURES:=squashfs fpu gpio pcie usb usbgadget
 CPU_TYPE:=mpcore
 CPU_SUBTYPE:=vfp
-MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
-
-LINUX_VERSION:=3.8.13
-
-include $(INCLUDE_DIR)/target.mk
+KERNEL_PATCHVER:=4.19
 
 define Target/Description
        Build images for Cavium Networks Econa CNS3xxx based boards,
        eg. the Gateworks Laguna family
 endef
 
-KERNELNAME:="zImage"
+include $(INCLUDE_DIR)/target.mk
+
+KERNELNAME:=zImage
 
-DEFAULT_PACKAGES += kmod-ath9k kmod-usb2 wpad-mini
+DEFAULT_PACKAGES += kmod-ath9k kmod-usb2 wpad-basic-wolfssl
 
 $(eval $(call BuildTarget))