treewide: use wpad-basic-wolfssl as default
[openwrt/staging/dedeckeh.git] / target / linux / cns3xxx / Makefile
index c944d1c1a584d0ee69f9ba8a3917d361db63fe81..04df322b64c9f02a625b0247cc19b81e158882ae 100644 (file)
@@ -10,20 +10,19 @@ ARCH:=arm
 BOARD:=cns3xxx
 BOARDNAME:=Cavium Networks Econa CNS3xxx
 FEATURES:=squashfs fpu gpio pcie usb usbgadget
-CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -fno-caller-saves
-MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
-
-LINUX_VERSION:=3.8.6
-
-include $(INCLUDE_DIR)/target.mk
+CPU_TYPE:=mpcore
+CPU_SUBTYPE:=vfp
+KERNEL_PATCHVER:=4.19
 
 define Target/Description
        Build images for Cavium Networks Econa CNS3xxx based boards,
        eg. the Gateworks Laguna family
 endef
 
-KERNELNAME:="uImage"
+include $(INCLUDE_DIR)/target.mk
+
+KERNELNAME:=zImage
 
-DEFAULT_PACKAGES += kmod-ath9k kmod-usb2 wpad-mini
+DEFAULT_PACKAGES += kmod-ath9k kmod-usb2 wpad-basic-wolfssl
 
 $(eval $(call BuildTarget))