cns3xxx: update to linux 3.10
[openwrt/svn-archive/archive.git] / target / linux / cns3xxx / patches-3.8 / 070-i2c_support.patch
diff --git a/target/linux/cns3xxx/patches-3.8/070-i2c_support.patch b/target/linux/cns3xxx/patches-3.8/070-i2c_support.patch
deleted file mode 100644 (file)
index bdb19d6..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
---- a/drivers/i2c/busses/Kconfig
-+++ b/drivers/i2c/busses/Kconfig
-@@ -347,6 +347,18 @@ config I2C_CBUS_GPIO
-         This driver can also be built as a module.  If so, the module
-         will be called i2c-cbus-gpio.
-+config I2C_CNS3XXX
-+      tristate "Cavium CNS3xxx I2C driver"
-+      depends on ARCH_CNS3XXX
-+      help
-+        Support for Cavium CNS3xxx I2C controller driver.
-+
-+        This driver can also be built as a module.  If so, the module
-+        will be called i2c-cns3xxx.
-+
-+        Please note that this driver might be needed to bring up other
-+        devices such as Cavium CNS3xxx Ethernet.
-+
- config I2C_CPM
-       tristate "Freescale CPM1 or CPM2 (MPC8xx/826x)"
-       depends on (CPM1 || CPM2) && OF_I2C
---- a/drivers/i2c/busses/Makefile
-+++ b/drivers/i2c/busses/Makefile
-@@ -87,6 +87,7 @@ obj-$(CONFIG_I2C_ACORN)              += i2c-acorn.o
- obj-$(CONFIG_I2C_ELEKTOR)     += i2c-elektor.o
- obj-$(CONFIG_I2C_PCA_ISA)     += i2c-pca-isa.o
- obj-$(CONFIG_I2C_SIBYTE)      += i2c-sibyte.o
-+obj-$(CONFIG_I2C_CNS3XXX)     += i2c-cns3xxx.o
- obj-$(CONFIG_SCx200_ACB)      += scx200_acb.o
- obj-$(CONFIG_SCx200_I2C)      += scx200_i2c.o