ep93xx: moved to targets feed
[openwrt/svn-archive/archive.git] / target / linux / ep93xx / image / Makefile
diff --git a/target/linux/ep93xx/image/Makefile b/target/linux/ep93xx/image/Makefile
deleted file mode 100644 (file)
index 0d5a289..0000000
+++ /dev/null
@@ -1,41 +0,0 @@
-#
-# Copyright (C) 2009-2010 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/image.mk
-
-UIMAGE:=$(BIN_DIR)/$(IMG_PREFIX)-uImage
-fs_squash:=squashfs-only
-fs_all:=all
-fs_4k:=4k
-fs_64k:=64k
-fs_128k:=128k
-
-define Image/BuildKernel
-       cp $(KDIR)/uImage $(UIMAGE)
-ifeq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
-       cp $(KDIR)/uImage-initramfs $(UIMAGE)-initramfs
-endif
-endef
-
-define Image/Build/jffs2-64k
-       dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-$(1).img bs=64k conv=sync
-endef
-
-define Image/Build/jffs2-128k
-       dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-$(1).img bs=128k conv=sync
-endef
-
-define Image/Build/squashfs
-       $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
-       dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-$(1).img bs=128k conv=sync
-endef
-
-define Image/Build
-       $(call Image/Build/$(1),$(1))
-endef
-
-$(eval $(call BuildImage))