enable usb support by default.
[openwrt/staging/chunkeey.git] / target / linux / etrax / modules.mk
diff --git a/target/linux/etrax/modules.mk b/target/linux/etrax/modules.mk
deleted file mode 100644 (file)
index 5aef152..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
-#
-# Copyright (C) 2010 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define KernelPackage/usb-etrax
-  SUBMENU:=$(USB_MENU)
-  TITLE:=Support for the ETRAX USB host controller
-  KCONFIG:=CONFIG_ETRAX_USB_HOST \
-       CONFIG_ETRAX_USB_HOST_PORT1=y CONFIG_ETRAX_USB_HOST_PORT2=y
-  FILES:=$(LINUX_DIR)/drivers/usb/host/hc-crisv10.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,50,hc-crisv10,1)
-  $(call AddDepends/usb,@TARGET_etrax)
-endef
-
-define KernelPackage/usb-etrax/description
- Kernel support for the ETRAX USB host controller
-endef
-
-$(eval $(call KernelPackage,usb-etrax))