kernel: bump 4.19 to 4.19.93
[openwrt/staging/dedeckeh.git] / target / linux / generic / hack-4.19 / 930-crashlog.patch
index 3bb3e77778353043785026ebede55ab36d3dc972..bb16f22915fa9f3727cb63a229d92071532d0c90 100644 (file)
@@ -41,7 +41,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 +#endif
 --- a/init/Kconfig
 +++ b/init/Kconfig
-@@ -1041,6 +1041,10 @@ config RELAY
+@@ -1049,6 +1049,10 @@ config RELAY
  
          If unsure, say N.
  
@@ -54,7 +54,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        help
 --- a/kernel/Makefile
 +++ b/kernel/Makefile
-@@ -116,6 +116,7 @@ obj-$(CONFIG_TORTURE_TEST) += torture.o
+@@ -114,6 +114,7 @@ obj-$(CONFIG_TORTURE_TEST) += torture.o
  obj-$(CONFIG_HAS_IOMEM) += iomem.o
  obj-$(CONFIG_ZONE_DEVICE) += memremap.o
  obj-$(CONFIG_RSEQ) += rseq.o
@@ -280,7 +280,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 +module_init(crashlog_init_fs);
 --- a/kernel/module.c
 +++ b/kernel/module.c
-@@ -256,6 +256,9 @@ static void mod_update_bounds(struct mod
+@@ -251,6 +251,9 @@ static void mod_update_bounds(struct mod
  #ifdef CONFIG_KGDB_KDB
  struct list_head *kdb_modules = &modules; /* kdb needs the list of modules */
  #endif /* CONFIG_KGDB_KDB */