kernel: add a missing dependency for the mv_cesa crypto driver
[openwrt/svn-archive/archive.git] / target / linux / generic / patches-2.6.38 / 208-mips_oprofile_fix.patch
index 2841ed883e49bf016b6bf53bd12fb5acccb77121..f83c96bb81f64a65764dc81705927b24c3933353 100644 (file)
@@ -1,15 +1,3 @@
---- a/arch/mips/Makefile
-+++ b/arch/mips/Makefile
-@@ -48,6 +48,9 @@ ifneq ($(SUBARCH),$(ARCH))
-   endif
- endif
-+ifndef CONFIG_PROFILING
-+  cflags-y := -ffunction-sections
-+endif
- ifdef CONFIG_FUNCTION_GRAPH_TRACER
-   ifndef KBUILD_MCOUNT_RA_ADDRESS
-     ifeq ($(call cc-option-yn,-mmcount-ra-address), y)
 --- a/arch/mips/oprofile/op_model_mipsxx.c
 +++ b/arch/mips/oprofile/op_model_mipsxx.c
 @@ -298,6 +298,11 @@ static void reset_counters(void *arg)