[generic]: add initial 3.13 support
[openwrt/svn-archive/archive.git] / target / linux / generic / patches-3.13 / 259-regmap_dynamic.patch
diff --git a/target/linux/generic/patches-3.13/259-regmap_dynamic.patch b/target/linux/generic/patches-3.13/259-regmap_dynamic.patch
new file mode 100644 (file)
index 0000000..e85b2d8
--- /dev/null
@@ -0,0 +1,76 @@
+--- a/drivers/base/regmap/Kconfig
++++ b/drivers/base/regmap/Kconfig
+@@ -3,23 +3,28 @@
+ # subsystems should select the appropriate symbols.
+ config REGMAP
+-      default y if (REGMAP_I2C || REGMAP_SPI || REGMAP_SPMI || REGMAP_MMIO || REGMAP_IRQ)
+       select LZO_COMPRESS
+       select LZO_DECOMPRESS
+       select IRQ_DOMAIN if REGMAP_IRQ
+-      bool
++      tristate "Regmap"
+ config REGMAP_I2C
+-      tristate
++      select REGMAP
++      tristate "Regmap I2C
+ config REGMAP_SPI
+-      tristate
++      select REGMAP
++      depends on SPI_MASTER
++      tristate "Regmap SPI"
+ config REGMAP_SPMI
++      select REGMAP
+       tristate
+ config REGMAP_MMIO
++      select REGMAP
+       tristate
+ config REGMAP_IRQ
++      select REGMAP
+       bool
+--- a/include/linux/regmap.h
++++ b/include/linux/regmap.h
+@@ -49,7 +49,7 @@ struct reg_default {
+       unsigned int def;
+ };
+-#ifdef CONFIG_REGMAP
++#if IS_ENABLED(CONFIG_REGMAP)
+ enum regmap_endian {
+       /* Unspecified -> 0 -> Backwards compatible default */
+--- a/drivers/base/regmap/Makefile
++++ b/drivers/base/regmap/Makefile
+@@ -1,6 +1,8 @@
+-obj-$(CONFIG_REGMAP) += regmap.o regcache.o
+-obj-$(CONFIG_REGMAP) += regcache-rbtree.o regcache-lzo.o regcache-flat.o
+-obj-$(CONFIG_DEBUG_FS) += regmap-debugfs.o
++regmap-core-objs = regmap.o regcache.o regcache-rbtree.o regcache-lzo.o regcache-flat.o
++ifdef CONFIG_DEBUG_FS
++regmap-core-objs += regmap-debugfs.o
++endif
++obj-$(CONFIG_REGMAP) += regmap-core.o
+ obj-$(CONFIG_REGMAP_I2C) += regmap-i2c.o
+ obj-$(CONFIG_REGMAP_SPI) += regmap-spi.o
+ obj-$(CONFIG_REGMAP_SPMI) += regmap-spmi.o
+--- a/drivers/base/regmap/regmap.c
++++ b/drivers/base/regmap/regmap.c
+@@ -13,6 +13,7 @@
+ #include <linux/device.h>
+ #include <linux/slab.h>
+ #include <linux/export.h>
++#include <linux/module.h>
+ #include <linux/mutex.h>
+ #include <linux/err.h>
+ #include <linux/rbtree.h>
+@@ -2235,3 +2236,5 @@ static int __init regmap_initcall(void)
+       return 0;
+ }
+ postcore_initcall(regmap_initcall);
++
++MODULE_LICENSE("GPL");