generic: drop 3.14
[openwrt/openwrt.git] / target / linux / generic / patches-3.14 / 320-ppc4xx_optimization.patch
diff --git a/target/linux/generic/patches-3.14/320-ppc4xx_optimization.patch b/target/linux/generic/patches-3.14/320-ppc4xx_optimization.patch
deleted file mode 100644 (file)
index 064cc79..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
-Upstream doesn't optimize the kernel and bootwrappers for ppc44x because
-they still want to support gcc 3.3 -- well, we don't.
-
---- a/arch/powerpc/Makefile
-+++ b/arch/powerpc/Makefile
-@@ -191,7 +191,8 @@ ifeq ($(CONFIG_FUNCTION_TRACER),y)
- KBUILD_CFLAGS         += -mno-sched-epilog
- endif
--cpu-as-$(CONFIG_4xx)          += -Wa,-m405
-+cpu-as-$(CONFIG_40x)          += -Wa,-m405
-+cpu-as-$(CONFIG_44x)          += -Wa,-m440
- cpu-as-$(CONFIG_ALTIVEC)      += -Wa,-maltivec
- cpu-as-$(CONFIG_E200)         += -Wa,-me200
---- a/arch/powerpc/boot/Makefile
-+++ b/arch/powerpc/boot/Makefile
-@@ -39,10 +39,10 @@ BOOTCFLAGS += -I$(obj) -I$(srctree)/$(ob
- DTC_FLAGS     ?= -p 1024
- $(obj)/4xx.o: BOOTCFLAGS += -mcpu=405
--$(obj)/ebony.o: BOOTCFLAGS += -mcpu=405
-+$(obj)/ebony.o: BOOTCFLAGS += -mcpu=440
- $(obj)/cuboot-hotfoot.o: BOOTCFLAGS += -mcpu=405
--$(obj)/cuboot-taishan.o: BOOTCFLAGS += -mcpu=405
--$(obj)/cuboot-katmai.o: BOOTCFLAGS += -mcpu=405
-+$(obj)/cuboot-taishan.o: BOOTCFLAGS += -mcpu=440
-+$(obj)/cuboot-katmai.o: BOOTCFLAGS += -mcpu=440
- $(obj)/cuboot-acadia.o: BOOTCFLAGS += -mcpu=405
- $(obj)/treeboot-walnut.o: BOOTCFLAGS += -mcpu=405
- $(obj)/treeboot-iss4xx.o: BOOTCFLAGS += -mcpu=405