kernel: rewrite the phy packet hook, put it in the network stack to avoid having...
[openwrt/openwrt.git] / target / linux / generic / patches-3.3 / 723-phy_ip175c.patch
index 0ac339e9a2f2dd1e8cc6f813b98d8ee21a9554aa..8eff10cf45b6580f3404c6f89643dfc80c7cc313 100644 (file)
@@ -1,8 +1,8 @@
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
-@@ -112,6 +112,10 @@ config ADM6996_PHY
- config MVSWITCH_PHY
+@@ -117,6 +117,10 @@ config MVSWITCH_PHY
        tristate "Driver for Marvell 88E6060 switches"
+       select ETHERNET_PACKET_MANGLE
  
 +config IP17XX_PHY
 +      tristate "Driver for IC+ IP17xx switches"
@@ -13,7 +13,7 @@
        depends on PHYLIB=y
 --- a/drivers/net/phy/Makefile
 +++ b/drivers/net/phy/Makefile
-@@ -16,6 +16,7 @@ obj-$(CONFIG_BCM63XX_PHY)    += bcm63xx.o
+@@ -18,6 +18,7 @@ obj-$(CONFIG_BCM63XX_PHY)    += bcm63xx.o
  obj-$(CONFIG_ICPLUS_PHY)      += icplus.o
  obj-$(CONFIG_ADM6996_PHY)     += adm6996.o
  obj-$(CONFIG_MVSWITCH_PHY)    += mvswitch.o