generic: early (incomplete!) 4.0 support
[openwrt/openwrt.git] / target / linux / generic / patches-4.0 / 403-mtd-hook-mtdsplit-to-Kbuild.patch
diff --git a/target/linux/generic/patches-4.0/403-mtd-hook-mtdsplit-to-Kbuild.patch b/target/linux/generic/patches-4.0/403-mtd-hook-mtdsplit-to-Kbuild.patch
new file mode 100644 (file)
index 0000000..0cf1c38
--- /dev/null
@@ -0,0 +1,22 @@
+--- a/drivers/mtd/Kconfig
++++ b/drivers/mtd/Kconfig
+@@ -27,6 +27,8 @@ config MTD_SPLIT_FIRMWARE_NAME
+       depends on MTD_SPLIT_FIRMWARE
+       default "firmware"
++source "drivers/mtd/mtdsplit/Kconfig"
++
+ endmenu
+ config MTD_TESTS
+--- a/drivers/mtd/Makefile
++++ b/drivers/mtd/Makefile
+@@ -6,6 +6,8 @@
+ obj-$(CONFIG_MTD)             += mtd.o
+ mtd-y                         := mtdcore.o mtdsuper.o mtdconcat.o mtdpart.o mtdchar.o
++obj-$(CONFIG_MTD_SPLIT)               += mtdsplit/
++
+ obj-$(CONFIG_MTD_OF_PARTS)    += ofpart.o
+ obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o
+ obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o