kernel: remove linux 4.0 support
[openwrt/staging/chunkeey.git] / target / linux / generic / patches-4.0 / 724-phy_ar8216.patch
diff --git a/target/linux/generic/patches-4.0/724-phy_ar8216.patch b/target/linux/generic/patches-4.0/724-phy_ar8216.patch
deleted file mode 100644 (file)
index 37602fa..0000000
+++ /dev/null
@@ -1,24 +0,0 @@
---- a/drivers/net/phy/Kconfig
-+++ b/drivers/net/phy/Kconfig
-@@ -147,6 +147,11 @@ config IP17XX_PHY
-       tristate "Driver for IC+ IP17xx switches"
-       select SWCONFIG
-+config AR8216_PHY
-+      tristate "Driver for Atheros AR8216 switches"
-+      select ETHERNET_PACKET_MANGLE
-+      select SWCONFIG
-+
- config FIXED_PHY
-       tristate "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
-       depends on PHYLIB
---- a/drivers/net/phy/Makefile
-+++ b/drivers/net/phy/Makefile
-@@ -22,6 +22,7 @@ obj-$(CONFIG_ADM6996_PHY)    += adm6996.o
- obj-$(CONFIG_MVSWITCH_PHY)    += mvswitch.o
- obj-$(CONFIG_IP17XX_PHY)      += ip17xx.o
- obj-$(CONFIG_REALTEK_PHY)     += realtek.o
-+obj-$(CONFIG_AR8216_PHY)      += ar8216.o ar8327.o
- obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
- obj-$(CONFIG_FIXED_PHY)               += fixed_phy.o
- obj-$(CONFIG_MDIO_BITBANG)    += mdio-bitbang.o