kernel: add linux 4.4 support
[openwrt/staging/lynxis/omap.git] / target / linux / generic / patches-4.4 / 302-mips_no_branch_likely.patch
diff --git a/target/linux/generic/patches-4.4/302-mips_no_branch_likely.patch b/target/linux/generic/patches-4.4/302-mips_no_branch_likely.patch
new file mode 100644 (file)
index 0000000..44c6b04
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/arch/mips/Makefile
++++ b/arch/mips/Makefile
+@@ -87,7 +87,7 @@ all-$(CONFIG_SYS_SUPPORTS_ZBOOT)+= vmlin
+ # machines may also.  Since BFD is incredibly buggy with respect to
+ # crossformat linking we rely on the elf2ecoff tool for format conversion.
+ #
+-cflags-y                      += -G 0 -mno-abicalls -fno-pic -pipe
++cflags-y                      += -G 0 -mno-abicalls -fno-pic -pipe -mno-branch-likely
+ cflags-y                      += -msoft-float
+ LDFLAGS_vmlinux                       += -G 0 -static -n -nostdlib --gc-sections
+ KBUILD_AFLAGS_MODULE          += -mlong-calls