kernel: add linux 4.4 support
[openwrt/staging/lynxis/omap.git] / target / linux / generic / patches-4.4 / 733-phy_mvsw61xx.patch
diff --git a/target/linux/generic/patches-4.4/733-phy_mvsw61xx.patch b/target/linux/generic/patches-4.4/733-phy_mvsw61xx.patch
new file mode 100644 (file)
index 0000000..2e13136
--- /dev/null
@@ -0,0 +1,23 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -181,6 +181,10 @@ config MVSWITCH_PHY
+       tristate "Driver for Marvell 88E6060 switches"
+       select ETHERNET_PACKET_MANGLE
++config MVSW61XX_PHY
++      tristate "Driver for Marvell 88E6171/6172 switches"
++      select SWCONFIG
++
+ config IP17XX_PHY
+       tristate "Driver for IC+ IP17xx switches"
+       select SWCONFIG
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -24,6 +24,7 @@ obj-$(CONFIG_BCM_CYGNUS_PHY) += bcm-cygn
+ obj-$(CONFIG_ICPLUS_PHY)      += icplus.o
+ obj-$(CONFIG_ADM6996_PHY)     += adm6996.o
+ obj-$(CONFIG_MVSWITCH_PHY)    += mvswitch.o
++obj-$(CONFIG_MVSW61XX_PHY)    += mvsw61xx.o
+ obj-$(CONFIG_IP17XX_PHY)      += ip17xx.o
+ obj-$(CONFIG_REALTEK_PHY)     += realtek.o
+ obj-$(CONFIG_AR8216_PHY)      += ar8216.o ar8327.o