kernel: add linux 4.4 support
[openwrt/openwrt.git] / target / linux / generic / patches-4.4 / 940-ocf_kbuild_integration.patch
diff --git a/target/linux/generic/patches-4.4/940-ocf_kbuild_integration.patch b/target/linux/generic/patches-4.4/940-ocf_kbuild_integration.patch
new file mode 100644 (file)
index 0000000..8b0cc2b
--- /dev/null
@@ -0,0 +1,20 @@
+--- a/crypto/Kconfig
++++ b/crypto/Kconfig
+@@ -1654,3 +1654,6 @@ source crypto/asymmetric_keys/Kconfig
+ source certs/Kconfig
+ endif # if CRYPTO
++
++source "crypto/ocf/Kconfig"
++
+--- a/crypto/Makefile
++++ b/crypto/Makefile
+@@ -123,6 +123,8 @@ obj-$(CONFIG_CRYPTO_USER_API_SKCIPHER) +
+ obj-$(CONFIG_CRYPTO_USER_API_RNG) += algif_rng.o
+ obj-$(CONFIG_CRYPTO_USER_API_AEAD) += algif_aead.o
++obj-$(CONFIG_OCF_OCF) += ocf/
++
+ #
+ # generic algorithms and the async_tx api
+ #