rename generic-2.6/patches to generic-2.6/patches-2.6.21
[openwrt/svn-archive/archive.git] / target / linux / generic-2.6 / patches-2.6.21 / 010-disable_old_squashfs_compatibility.patch
diff --git a/target/linux/generic-2.6/patches-2.6.21/010-disable_old_squashfs_compatibility.patch b/target/linux/generic-2.6/patches-2.6.21/010-disable_old_squashfs_compatibility.patch
new file mode 100644 (file)
index 0000000..5549861
--- /dev/null
@@ -0,0 +1,23 @@
+Index: linux-2.6.21.7/fs/squashfs/Makefile
+===================================================================
+--- linux-2.6.21.7.orig/fs/squashfs/Makefile
++++ linux-2.6.21.7/fs/squashfs/Makefile
+@@ -4,4 +4,3 @@
+ obj-$(CONFIG_SQUASHFS) += squashfs.o
+ squashfs-y += inode.o
+-squashfs-y += squashfs2_0.o
+Index: linux-2.6.21.7/fs/squashfs/squashfs.h
+===================================================================
+--- linux-2.6.21.7.orig/fs/squashfs/squashfs.h
++++ linux-2.6.21.7/fs/squashfs/squashfs.h
+@@ -24,6 +24,9 @@
+ #ifdef CONFIG_SQUASHFS_1_0_COMPATIBILITY
+ #undef CONFIG_SQUASHFS_1_0_COMPATIBILITY
+ #endif
++#ifdef CONFIG_SQUASHFS_2_0_COMPATIBILITY
++#undef CONFIG_SQUASHFS_2_0_COMPATIBILITY
++#endif
+ #ifdef SQUASHFS_TRACE
+ #define TRACE(s, args...)     printk(KERN_NOTICE "SQUASHFS: "s, ## args)