rename generic-2.6/patches to generic-2.6/patches-2.6.21
[openwrt/svn-archive/archive.git] / target / linux / generic-2.6 / patches-2.6.21 / 420-gpiodev.patch
diff --git a/target/linux/generic-2.6/patches-2.6.21/420-gpiodev.patch b/target/linux/generic-2.6/patches-2.6.21/420-gpiodev.patch
new file mode 100644 (file)
index 0000000..a4f2236
--- /dev/null
@@ -0,0 +1,26 @@
+--- a/drivers/char/Kconfig
++++ b/drivers/char/Kconfig
+@@ -984,6 +984,13 @@
+         If compiled as a module, it will be called cs5535_gpio.
++config GPIO_DEVICE
++      tristate "GPIO device support"
++      depends on GENERIC_GPIO
++      help
++        Say Y to enable Linux GPIO device support.  This allows control of
++        GPIO pins using a character device
++
+ config GPIO_VR41XX
+       tristate "NEC VR4100 series General-purpose I/O Unit support"
+       depends on CPU_VR41XX
+--- a/drivers/char/Makefile
++++ b/drivers/char/Makefile
+@@ -90,6 +90,7 @@
+ obj-$(CONFIG_PC8736x_GPIO)    += pc8736x_gpio.o
+ obj-$(CONFIG_NSC_GPIO)                += nsc_gpio.o
+ obj-$(CONFIG_CS5535_GPIO)     += cs5535_gpio.o
++obj-$(CONFIG_GPIO_DEVICE)     += gpio_dev.o
+ obj-$(CONFIG_GPIO_VR41XX)     += vr41xx_giu.o
+ obj-$(CONFIG_TANBAC_TB0219)   += tb0219.o
+ obj-$(CONFIG_TELCLOCK)                += tlclk.o