remove 2.6.23 support, as the last target using that has been nuked, too
[openwrt/openwrt.git] / target / linux / generic-2.6 / patches-2.6.23 / 910-arm_binutils_build_id_fix.patch
diff --git a/target/linux/generic-2.6/patches-2.6.23/910-arm_binutils_build_id_fix.patch b/target/linux/generic-2.6/patches-2.6.23/910-arm_binutils_build_id_fix.patch
deleted file mode 100644 (file)
index 440f060..0000000
+++ /dev/null
@@ -1,35 +0,0 @@
-From: Lennert Buytenhek <buytenh@wantstofly.org>
-Date: Fri, 12 Oct 2007 13:38:54 +0000 (+0100)
-Subject: [ARM] 4600/1: fix kernel build failure with build-id-supporting binutils
-X-Git-Tag: v2.6.24-rc1~1273^2~3
-X-Git-Url: http://git.kernel.org/?p=linux%2Fkernel%2Fgit%2Ftorvalds%2Flinux-2.6.git;a=commitdiff_plain;h=1e621a8e3752367d4aae78a8ab00a18fb2793f34;hp=033b8ffe3f1ea8174d51d125838ac6deea60f63f
-
-[ARM] 4600/1: fix kernel build failure with build-id-supporting binutils
-
-Newer versions of binutils support --build-id, which adds an ELF
-note section called ".note.gnu.build-id" to the output.  On the ARM
-kernel build, because there is no explicit mention of this section
-in the shipped ld script, this section is placed at vaddr 0x00000000
-(whereas the normal kernel text/data typically starts at vaddr
-0xc0008000), causing the output of objcopy (Image) to produce a 3G+
-file.
-
-This patch makes objcopy strip the .note.gnu.build-id section from
-the Image file along with all other note sections, which fixes the
-build.
-
-Signed-off-by: Lennert Buytenhek <buytenh@wantstofly.org>
-Signed-off-by: Russell King <rmk+kernel@arm.linux.org.uk>
----
-
---- a/arch/arm/Makefile
-+++ b/arch/arm/Makefile
-@@ -12,7 +12,7 @@
- LDFLAGS_vmlinux       :=-p --no-undefined -X
- CPPFLAGS_vmlinux.lds = -DTEXT_OFFSET=$(TEXT_OFFSET)
--OBJCOPYFLAGS  :=-O binary -R .note -R .comment -S
-+OBJCOPYFLAGS  :=-O binary -R .note -R .note.gnu.build-id -R .comment -S
- GZFLAGS               :=-9
- #CFLAGS               +=-pipe
- # Explicitly specifiy 32-bit ARM ISA since toolchain default can be -mthumb: