* add a prerelease IMQ patch for 2.6.25 * reenable IMQ in the kernel config * resync...
[openwrt/openwrt.git] / target / linux / generic-2.6 / patches-2.6.25 / 110-ipp2p_0.8.1rc1.patch
index eb9e4ddd546ef5267c8859f6699383a496cf65b0..cd1abfaf6da2c547d33abbb1645cb8c25d0cf8b3 100644 (file)
@@ -1,7 +1,5 @@
-Index: linux-2.6.23.1/include/linux/netfilter_ipv4/ipt_ipp2p.h
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.23.1/include/linux/netfilter_ipv4/ipt_ipp2p.h    2007-11-19 18:22:19.000000000 -0600
+--- /dev/null
++++ b/include/linux/netfilter_ipv4/ipt_ipp2p.h
 @@ -0,0 +1,31 @@
 +#ifndef __IPT_IPP2P_H
 +#define __IPT_IPP2P_H
@@ -34,10 +32,8 @@ Index: linux-2.6.23.1/include/linux/netfilter_ipv4/ipt_ipp2p.h
 +#define IPP2P_MUTE            (1 << 14)
 +#define IPP2P_WASTE           (1 << 15)
 +#define IPP2P_XDCC            (1 << 16)
-Index: linux-2.6.23.1/net/ipv4/netfilter/ipt_ipp2p.c
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.23.1/net/ipv4/netfilter/ipt_ipp2p.c      2007-11-19 18:22:19.000000000 -0600
+--- /dev/null
++++ b/net/ipv4/netfilter/ipt_ipp2p.c
 @@ -0,0 +1,856 @@
 +#if defined(MODVERSIONS)
 +#include <linux/modversions.h>
@@ -895,11 +891,9 @@ Index: linux-2.6.23.1/net/ipv4/netfilter/ipt_ipp2p.c
 +module_exit(fini);
 +
 +
-Index: linux-2.6.23.1/net/ipv4/netfilter/Kconfig
-===================================================================
---- linux-2.6.23.1.orig/net/ipv4/netfilter/Kconfig     2007-11-19 18:21:55.000000000 -0600
-+++ linux-2.6.23.1/net/ipv4/netfilter/Kconfig  2007-11-19 18:22:19.000000000 -0600
-@@ -63,6 +63,12 @@
+--- a/net/ipv4/netfilter/Kconfig
++++ b/net/ipv4/netfilter/Kconfig
+@@ -57,6 +57,12 @@
          To compile it as a module, choose M here.  If unsure, say N.
  
  # The matches.
@@ -912,16 +906,14 @@ Index: linux-2.6.23.1/net/ipv4/netfilter/Kconfig
  config IP_NF_MATCH_RECENT
        tristate '"recent" match support'
        depends on IP_NF_IPTABLES
-Index: linux-2.6.23.1/net/ipv4/netfilter/Makefile
-===================================================================
---- linux-2.6.23.1.orig/net/ipv4/netfilter/Makefile    2007-11-19 18:21:55.000000000 -0600
-+++ linux-2.6.23.1/net/ipv4/netfilter/Makefile 2007-11-19 18:23:45.000000000 -0600
-@@ -50,6 +50,8 @@
+--- a/net/ipv4/netfilter/Makefile
++++ b/net/ipv4/netfilter/Makefile
+@@ -47,6 +47,8 @@
+ obj-$(CONFIG_IP_NF_MATCH_RECENT) += ipt_recent.o
  obj-$(CONFIG_IP_NF_MATCH_TTL) += ipt_ttl.o
- obj-$(CONFIG_IP_NF_MATCH_ADDRTYPE) += ipt_addrtype.o
  
 +obj-$(CONFIG_IP_NF_MATCH_IPP2P) += ipt_ipp2p.o
 +
  # targets
- obj-$(CONFIG_IP_NF_TARGET_REJECT) += ipt_REJECT.o
- obj-$(CONFIG_IP_NF_TARGET_TOS) += ipt_TOS.o
+ obj-$(CONFIG_IP_NF_TARGET_CLUSTERIP) += ipt_CLUSTERIP.o
+ obj-$(CONFIG_IP_NF_TARGET_ECN) += ipt_ECN.o