revert 15922 - add back 2.6.29 kernel support
[openwrt/openwrt.git] / target / linux / generic-2.6 / patches-2.6.29 / 650-swconfig.patch
diff --git a/target/linux/generic-2.6/patches-2.6.29/650-swconfig.patch b/target/linux/generic-2.6/patches-2.6.29/650-swconfig.patch
new file mode 100644 (file)
index 0000000..6825037
--- /dev/null
@@ -0,0 +1,25 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -13,6 +13,12 @@ menuconfig PHYLIB
+ if PHYLIB
++config SWCONFIG
++      tristate "Switch configuration API"
++      ---help---
++        Switch configuration API using netlink. This allows
++        you to configure the VLAN features of certain switches.
++
+ comment "MII PHY device drivers"
+ config MARVELL_PHY
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -3,6 +3,7 @@
+ libphy-objs                   := phy.o phy_device.o mdio_bus.o
+ obj-$(CONFIG_PHYLIB)          += libphy.o
++obj-$(CONFIG_SWCONFIG)                += swconfig.o
+ obj-$(CONFIG_MARVELL_PHY)     += marvell.o
+ obj-$(CONFIG_DAVICOM_PHY)     += davicom.o
+ obj-$(CONFIG_CICADA_PHY)      += cicada.o