rename target/linux/generic-2.6 to generic
[openwrt/svn-archive/archive.git] / target / linux / generic-2.6 / patches-2.6.31 / 410-gpio_buttons.patch
diff --git a/target/linux/generic-2.6/patches-2.6.31/410-gpio_buttons.patch b/target/linux/generic-2.6/patches-2.6.31/410-gpio_buttons.patch
deleted file mode 100644 (file)
index 688f6fe..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
---- a/drivers/input/misc/Kconfig
-+++ b/drivers/input/misc/Kconfig
-@@ -269,4 +269,21 @@ config INPUT_DM355EVM
-         To compile this driver as a module, choose M here: the
-         module will be called dm355evm_keys.
-+
-+config INPUT_GPIO_BUTTONS
-+      tristate "Polled GPIO buttons interface"
-+      depends on GENERIC_GPIO
-+      select INPUT_POLLDEV
-+      help
-+        This driver implements support for buttons connected
-+        to GPIO pins of various CPUs (and some other chips).
-+
-+        Say Y here if your device has buttons connected
-+        directly to such GPIO pins.  Your board-specific
-+        setup logic must also provide a platform device,
-+        with configuration data saying which GPIOs are used.
-+
-+        To compile this driver as a module, choose M here: the
-+        module will be called gpio-buttons.
-+
- endif
---- a/drivers/input/misc/Makefile
-+++ b/drivers/input/misc/Makefile
-@@ -26,3 +26,4 @@ obj-$(CONFIG_INPUT_TWL4030_PWRBUTTON)        +=
- obj-$(CONFIG_INPUT_UINPUT)            += uinput.o
- obj-$(CONFIG_INPUT_WISTRON_BTNS)      += wistron_btns.o
- obj-$(CONFIG_INPUT_YEALINK)           += yealink.o
-+obj-$(CONFIG_INPUT_GPIO_BUTTONS)      += gpio_buttons.o