generic-2.6: add 2.6.34 preliminary support (patches)
[openwrt/openwrt.git] / target / linux / generic-2.6 / patches-2.6.34 / 660-phy_mvswitch.patch
diff --git a/target/linux/generic-2.6/patches-2.6.34/660-phy_mvswitch.patch b/target/linux/generic-2.6/patches-2.6.34/660-phy_mvswitch.patch
new file mode 100644 (file)
index 0000000..36551fd
--- /dev/null
@@ -0,0 +1,22 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -99,6 +99,9 @@ config ADM6996_PHY
+       ---help---
+         Currently supports the ADM6996F switch
++config MVSWITCH_PHY
++      tristate "Driver for Marvell 88E6060 switches"
++
+ config FIXED_PHY
+       bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
+       depends on PHYLIB=y
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -15,6 +15,7 @@ obj-$(CONFIG_BROADCOM_PHY)   += broadcom.o
+ obj-$(CONFIG_BCM63XX_PHY)     += bcm63xx.o
+ obj-$(CONFIG_ICPLUS_PHY)      += icplus.o
+ obj-$(CONFIG_ADM6996_PHY)     += adm6996.o
++obj-$(CONFIG_MVSWITCH_PHY)    += mvswitch.o
+ obj-$(CONFIG_REALTEK_PHY)     += realtek.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_FIXED_PHY)               += fixed.o