generic-2.6: add kernel 2.6.35 preliminary support (patches)
[openwrt/openwrt.git] / target / linux / generic-2.6 / patches-2.6.35 / 970-ocf_kbuild_integration.patch
diff --git a/target/linux/generic-2.6/patches-2.6.35/970-ocf_kbuild_integration.patch b/target/linux/generic-2.6/patches-2.6.35/970-ocf_kbuild_integration.patch
new file mode 100644 (file)
index 0000000..76413e9
--- /dev/null
@@ -0,0 +1,20 @@
+--- a/crypto/Kconfig
++++ b/crypto/Kconfig
+@@ -836,3 +836,6 @@ config CRYPTO_ANSI_CPRNG
+ source "drivers/crypto/Kconfig"
+ endif # if CRYPTO
++
++source "crypto/ocf/Kconfig"
++
+--- a/crypto/Makefile
++++ b/crypto/Makefile
+@@ -86,6 +86,8 @@ obj-$(CONFIG_CRYPTO_ANSI_CPRNG) += ansi_
+ obj-$(CONFIG_CRYPTO_TEST) += tcrypt.o
+ obj-$(CONFIG_CRYPTO_GHASH) += ghash-generic.o
++obj-$(CONFIG_OCF_OCF) += ocf/
++
+ #
+ # generic algorithms and the async_tx api
+ #