[ifxmips] adds dsl support, thank you infineon/lantiq
[openwrt/svn-archive/archive.git] / target / linux / ifxmips / Makefile
index e728921489a969eb3294bbca54a3e9331816fc8c..14ee8831f01f9f2d61bc9653049d11261509e3cf 100644 (file)
@@ -13,9 +13,10 @@ FEATURES:=squashfs jffs2 atm
 
 LINUX_VERSION:=2.6.30.9
 
+CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
+
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES+=uboot-ifxmips
-#kmod-pppoa ppp-mod-pppoa linux-atm atm-tools br2684ctl kmod-ifxmips-atm
+DEFAULT_PACKAGES+=kmod-pppoa ppp-mod-pppoa linux-atm atm-tools br2684ctl ifxmips-dsl-api ifxmips-dsl-control
 
 define Target/Description
        Build firmware images for Infineon Mips Controllers