rename the mx2 target to imx21
[openwrt/svn-archive/archive.git] / target / linux / imx21 / patches-2.6.34 / 010-mach-vp6500.patch
diff --git a/target/linux/imx21/patches-2.6.34/010-mach-vp6500.patch b/target/linux/imx21/patches-2.6.34/010-mach-vp6500.patch
new file mode 100644 (file)
index 0000000..8d1832b
--- /dev/null
@@ -0,0 +1,22 @@
+--- a/arch/arm/mach-mx2/Kconfig
++++ b/arch/arm/mach-mx2/Kconfig
+@@ -27,6 +27,12 @@ config MACH_MX21ADS
+         Include support for MX21ADS platform. This includes specific
+         configurations for the board and its peripherals.
++config MACH_VP6500
++      bool "Phillips VP6500 VoIP phone"
++      depends on MACH_MX21
++      help
++        Include support for the Phillips VP6500 VoIP phone.
++
+ config MACH_MX27ADS
+       bool "MX27ADS platform"
+       depends on MACH_MX27
+--- a/arch/arm/mach-mx2/Makefile
++++ b/arch/arm/mach-mx2/Makefile
+@@ -21,3 +21,4 @@ obj-$(CONFIG_MACH_CPUIMX27) += mach-cpui
+ obj-$(CONFIG_MACH_EUKREA_MBIMX27_BASEBOARD) += eukrea_mbimx27-baseboard.o
+ obj-$(CONFIG_MACH_PCA100) += mach-pca100.o
+ obj-$(CONFIG_MACH_MXT_TD60) += mach-mxt_td60.o
++obj-$(CONFIG_MACH_VP6500) += mach-vp6500.o